1067 Sort with Swap(0, i) (25分)【贪心】

1067 Sort with Swap(0, i) (25分)

Given any permutation of the numbers {0, 1, 2,..., N−1}, it is easy to sort them in increasing order. But what if Swap(0, *) is the ONLY operation that is allowed to use? For example, to sort {4, 0, 2, 1, 3} we may apply the swap operations in the following way:

Swap(0, 1) => {4, 1, 2, 0, 3}
Swap(0, 3) => {4, 1, 2, 3, 0}
Swap(0, 4) => {0, 1, 2, 3, 4}

Now you are asked to find the minimum number of swaps need to sort the given permutation of the first N nonnegative integers.

Input Specification:

Each input file contains one test case, which gives a positive N (≤10​5​​) followed by a permutation sequence of {0, 1, ..., N−1}. All the numbers in a line are separated by a space.

Output Specification:

For each case, simply print in a line the minimum number of swaps need to sort the given permutation.

Sample Input:

10
3 5 7 2 6 4 9 0 8 1

Sample Output:

9

题目大意:

给出0,1,...,N-1的一个序列,要求通过两两交换的方式将其变为递增序列,但是规定每次只能用0与其他数进行交换。求最小交换的次数。

解题思路:

由于必须使用数字0进行交换,因此我们很容易想到的策略是:如果数字0当前在i位置,则找到数字i当前所在的位置,然后把0与i进行交换。

但是我们会发现一个问题,就是:如果在交换的过程中如果数字0回到了0号位,但是当前还没有排序完,按照之前的算法就不能将其与一个确定的数字进行交换,这是就有必要想办法处理。通过思考发现,通过该策略,一旦一个非零的数字回到了它原本的位置,在后面的步骤中就不应当再让其与0交换,否则会让交换的次数变多。也就是说,非零的数字在回到其“本位”后将不再变动。

这会我们就可以这样处理:如果在交换的过程中出现数字0在0号位的情况,就随意选择一个还没有回到“本位”的数字,让其与数字0交换位置。显然,这样不会对已经在“本位”的数字产生影响,但却能继续进行交换。

#include<iostream>
#include<algorithm>
using namespace std;
int arr[100010];

int main()
{
	int n, ans = 0;
	cin >> n;
	int cnt = n - 1;     //cnt存放不在本位上的数的个数 
	int num;
	for (int i = 0; i < n; i++)
	{
		cin >> num;
		arr[num] = i;
		if (num == i && num != 0)
			cnt--;
	}
	int k = 1;
	while (cnt > 0)
	{
		if (arr[0] == 0)     //如果0在本位上
		{
			while (k < n)
			{
				if (arr[k] != k)
				{
					swap(arr[0], arr[k]);
					ans++;
					break;
				}
				k++;
			}
		}
		//如果不在本位
		while (arr[0] != 0)
		{
			swap(arr[0], arr[arr[0]]);
			ans++;
			cnt--;
		}
	}
	cout << ans << endl;
	return 0;
}

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

胡小涛

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值