1021 Deepest Root (25分)

121 篇文章 0 订阅
115 篇文章 0 订阅

A graph which is connected and acyclic can be considered a tree. The height of the tree depends on the selected root. Now you are supposed to find the root that results in a highest tree. Such a root is called the deepest root.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (≤10​4​​) which is the number of nodes, and hence the nodes are numbered from 1 to N. Then N−1 lines follow, each describes an edge by given the two adjacent nodes' numbers.

Output Specification:

For each test case, print each of the deepest roots in a line. If such a root is not unique, print them in increasing order of their numbers. In case that the given graph is not a tree, print Error: K components where K is the number of connected components in the graph.

Sample Input 1:

5
1 2
1 3
1 4
2 5

Sample Output 1:

3
4
5

Sample Input 2:

5
1 3
1 4
2 5
3 4

Sample Output 2:

Error: 2 components

 

题解:

思路:DFS+set

先确定是否是树可用DFS完成,

若是树,两次DFS,第一次取任意顶点,存储该点能达到的最深点集A;第二次从点集中任取一个作为顶点,求出最大深度的点集B。 

B即为所求。

1、A一定属于B的一部分。

因为从任意一点切入该树时,能到达的最大深度一定是最大深度根B集合的其中的点。

2、所有的最大路径一定会有一段公共重合区间,或是交于一点。

也就是B集合内的点可以互相到达。

 

#include <iostream>
#include <vector>
#include <algorithm>
#include <set>
using namespace std;

vector<vector<int>> G;
bool vis[10010];
int n, maxHeight = 0;
vector<int> temp;
set<int> s;

void DFS(int v, int height) {
	if (height > maxHeight)
	{
		temp.clear();
		temp.push_back(v);
		maxHeight = height;
	}
	else if (height == maxHeight)
	{
		temp.push_back(v);
	}

	vis[v] = true;
	for (int i = 0; i < G[v].size(); i++)
		if (vis[G[v][i]] == false)
			DFS(G[v][i], height + 1);
}

int main() {
	scanf("%d", &n);
	G.resize(n+1);
	for (int i = 0; i < n - 1; i++)
	{
		int a, b;
		scanf("%d%d", &a, &b);
		G[a].push_back(b);
		G[b].push_back(a);
	}

	int block = 0, s1 = 0;

	for (int i = 1; i <= n; i++)
	{
		if (vis[i] == false)
		{
			DFS(i, 1);
			if (i == 1)
			{
				if (temp.size() != 0) s1 = temp[0];
				for (int j = 0; j < temp.size(); j++)
					s.insert(temp[j]);
			}
			block++;
		}
	}

	if (block >= 2) printf("Error: %d components", block);
	else
	{
		temp.clear();
		maxHeight = 0;
		fill(vis, vis + 10010, false);
		DFS(s1, 1);
		for (int i = 0; i < temp.size(); i++)
			s.insert(temp[i]);
		for (auto it = s.begin(); it != s.end(); it++)
			printf("%d\n", *it);
	}
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值