Building Block 并查集

Building Block

                                                                     Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
                                                                                                 Total Submission(s): 4548    Accepted Submission(s): 1408


Problem Description
John are playing with blocks. There are N blocks (1 <= N <= 30000) numbered 1...N。Initially, there are N piles, and each pile contains one block. Then John do some operations P times (1 <= P <= 1000000). There are two kinds of operation:

M X Y : Put the whole pile containing block X up to the pile containing Y. If X and Y are in the same pile, just ignore this command. 
C X : Count the number of blocks under block X 

You are request to find out the output for each C operation.
 

Input
The first line contains integer P. Then P lines follow, each of which contain an operation describe above.
 

Output
Output the count for each C operations in one line.
 

Sample Input
  
  
6 M 1 6 C 1 M 2 4 M 2 6 C 3 C 4
 

Sample Output
  
  
1 0 2
 

Source
 

Recommend
gaojie   |   We have carefully selected several similar problems for you:   2819  2824  2821  2820  2822 
#include <cstdio>
#include <iostream>
using namespace std;

const int MAXN = 30000 + 10;
int Fa[MAXN], Under[MAXN], Num[MAXN];

void Init()
{
    for (int i = 0; i < MAXN; i++)
    {
        Fa[i] = i;              //初始化并查集,自成一个连通分量
        Num[i] = 1;             //i是根节点,初始化以它为根的树共有1个节点
    }
}

int Find(int x)
{
    if (x == Fa[x]) return x;
    int fa = Fa[x];
    Fa[x] = Find(Fa[x]);        //递归查找老祖宗
    Under[x] += Under[fa];      //加上父亲的
    return Fa[x];
}

void Union(int x, int y)
{
    int tx = Find(x), ty = Find(y); //先查找两者的祖先
    if (tx == ty) return;
    Fa[tx] = ty;                //合并
    Under[tx] = Num[ty];        //tx下面多了Num[ty]个
    Num[ty] += Num[tx];         //以ty为根的树多了Num[tx]个节点
    Num[tx] = 0;                //以tx为根的树没有结点(此时tx已经不是一个树的真正根节点)
}

int main()
{
    int t, x, y;
    char cmd[10];
    Init();
    scanf("%d", &t);
    while (t--)
    {
        scanf("%s", cmd);
        if (cmd[0] == 'C')
        {
            scanf("%d", &x);
            Find(x);
            printf("%d\n", Under[x]);
        }
        else
        {
            scanf("%d%d", &x, &y);
            Union(x, y);
        }
    }
    return 0;
}


//超时了的代码   不造怎么超了
#include<iostream>
#include<cstdio>
using namespace std;

int f[30005],vis[30005],down[30005],i,x,y,T;
char op[2];

int zbb(int x)
{
    if(f[x]!=x)
    {
        down[x]+=down[f[x]];
        return f[x]=zbb(f[x]);
    }
    else return x;
}

void hb(int x,int y)
{
    int a=zbb(x),b=zbb(y);
    if(a!=b)
    {
        f[a]=b;
        down[a]=vis[b];   //x堆底下面的数量为y堆的数量
        vis[b]+=vis[a];   //更新整个y堆加上合并x堆后的数量
    }
}

void init(int n)             //初始化
{
    for(i=0;i<n;i++)
    {
        f[i]=i;
        down[i]=0;
        vis[i]=1;
    }
}

    int main()
    {
        scanf("%d",&T);
        init(T);
        while(T--)
        {
            scanf("%s",op);
            if(op[0]=='M')
            {
                scanf("%d%d",&x,&y);
                hb(x,y);
            }
            if(op[0]=='C')
            {
                scanf("%d",&x);
                zbb(x);
                printf("%d\n",down[x]);
            }
        }
        return 0;
    }

### 回答1: DesignWare Building Block IP是Synopsys公司开发的一种IP(Intellectual Property)模块,用于硬件电路设计。该模块抽象了常见的全定制电路,为 SoC(System on Chip)设计提供了可重用的基础构件。 该IP模块与各种应用有关的专业知识相结合,能够实现数据通信、数字信号处理、计算机视觉、音频处理等各种功能。它可以帮助设计师加快开发速度,减少开发成本,提高设计质量和可靠性。 CSDN是中国最大的IT社区,为开发者提供技术交流和资源共享的平台。DesignWare Building Block IP被添加到CSDN的数据库中,使开发者可以在此找到它的详细信息、学习材料和技术支持。 DesignWare Building Block IP的出现,标志着整个IC设计行业的一个分水岭。以前,芯片设计的工作量大,业界需要大量的ASIC实现工程师。而 DesignWare Building Block IP 等IP 库可以使设计师摆脱无穷无尽的底层电路细节,更加注重系统级别的设计。这就让我们的设计变得容易得多,可以更专注于业务逻辑和性能。 综上所述,DesignWare Building Block IP是一种可重复使用、可裁剪和高度集成的IP模块。它将各种复杂的电路模块整合在一起,为SoC设计提供了必要的基础构件。这种技术的诞生和与CSDN 的结合,为芯片设计与开发社区极大地提高了效率,也为未来数字设计技术可重复性、可维护性和可扩展性提供了有力支持。 ### 回答2: DesignWare Building Block IP是世界领先的芯片设计公司Synopsys推出的一种基于IP(知识产权)的芯片设计解决方案,它是一种可扩展的IP集成平台,旨在简化开发流程,提高开发效率。 DesignWare Building Block IP基于标准化接口和协议,包括PCI Express、USB、Ethernet、DP、HDMI等主流接口和协议,可以使芯片开发人员快速构建高度集成化的SoC系统。 在DesignWare Building Block IP中,核心设计元素被组织成“块”,每个块都拥有完整的功能,可以被设计人员自由组合,以实现快速高效的芯片设计。 DesignWare Building Block IP还具有性能优越、可靠性高、灵活性强、易于集成等多种优点,可以大幅降低芯片设计风险和成本,缩短设计周期,加速产品上市。 CSDN是中国领先的专业技术社区,提供海量IT技术文章和教程,以及优质资源、工具和服务,成为IT从业者重要的学习和交流平台。 对于芯片设计人员来说,CSDN可以提供丰富的DesignWare Building Block IP资源和实践案例,帮助他们更好地了解和应用该解决方案,从而提高芯片设计效率和质量,促进产业创新和发展。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值