HDU-2476 String Painter(区间dp)

HDU-2476

问题描述

There are two strings A and B with equal length. Both strings are made up of lower case letters. Now you have a powerful string painter. With the help of the painter, you can change a segment of characters of a string to any other character you want. That is, after using the painter, the segment is made up of only one kind of character. Now your task is to change A to B using string painter. What’s the minimum number of operations?

Input

Input contains multiple cases. Each case consists of two lines:
The first line contains string A.
The second line contains string B.
The length of both strings will not be greater than 100.

Output

A single line contains one integer representing the answer.

Sample Input

zzzzzfzzzzz
abcdefedcba
abababababab
cdcdcdcdcdcd

Sample Output

6
7

题意

给你两个长度相等的a串和b串,问最少需要几次将a串变成b串。

个人理解

我一开始用直接涂色的方式涂,一直涂不对,反正就是涂不对。
网上题解的做法都是先算出b串从空串涂得所需要的步数,然后再算出a串涂成b串需要的步数。
算b串从空串涂得所需要的步数很简单,一个区间dp的固定格式。
算出a串涂成b串需要的步数就需要分两种情况了:

  1. 当前两个位置的颜色相同,不需要涂色,直接ans[i] = ans[i-1]
  2. 当前两个位置的颜色不相同,那么就遍历每个位置,中间的当作空串处理,递推关系如下:
    a n s [ i ] = m i n ( a n s [ i ] , a n s [ k ] + d p [ k + 1 ] [ j ] ) ( 1 ≤ k ≤ j − 1 ) ans[i] = min(ans[i],ans[k]+dp[k+1][j])(1 \leq k \leq j-1) ans[i]=min(ans[i],ans[k]+dp[k+1][j])(1kj1)

代码

#include <bits/stdc++.h>
using namespace std;
const int maxn = 110;

char a[maxn],b[maxn];
int len;
int dp[maxn][maxn];
int ans[maxn];

int main(){
	while(scanf("%s%s",a+1,b+1)!=EOF){
		memset(dp,0,sizeof(dp));
		len = strlen(a+1);
		for(int i = 1;i<=len;i++){
			dp[i][i] = 1;
		}
		for(int l = 2;l<=len;l++){
			for(int i = 1;i+l-1<=len;i++){
				int j = i+l-1;
				dp[i][j] = dp[i+1][j]+1;
				for(int k = i+1;k<=j;k++){
					dp[i][j] = min(dp[i][j],dp[i+1][k]+dp[k+1][j]+(b[i]!=b[k]));
				}
			}
		}
		for(int i = 1;i<=len;i++){
			ans[i] = dp[1][i];
		}
		for(int i = 1;i<=len;i++){
			if(a[i] == b[i]){
				ans[i] = ans[i-1];
			}
			for(int k = 1;k<i;k++){
				ans[i] = min(ans[i],ans[k]+dp[k+1][i]);
			}
		}
//		for(int i = 1;i<=len;i++){
//			printf("%d ",ans[i]);
//		}
//		putchar('\n');
		printf("%d\n",ans[len]);
	}	
	
	return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值