dijkstra(优先队列) HDU 1874

畅通工程续

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 52541    Accepted Submission(s): 19639


Problem Description
某省自从实行了很多年的畅通工程计划后,终于修建了很多路。不过路多了也不好,每次要从一个城镇到另一个城镇时,都有许多种道路方案可以选择,而某些方案要比另一些方案行走的距离要短很多。这让行人很困扰。

现在,已知起点和终点,请你计算出要从起点到终点,最短需要行走多少距离。
 

Input
本题目包含多组数据,请处理到文件结束。
每组数据第一行包含两个正整数N和M(0<N<200,0<M<1000),分别代表现有城镇的数目和已修建的道路的数目。城镇分别以0~N-1编号。
接下来是M行道路信息。每一行有三个整数A,B,X(0<=A,B<N,A!=B,0<X<10000),表示城镇A和城镇B之间有一条长度为X的双向道路。
再接下一行有两个整数S,T(0<=S,T<N),分别代表起点和终点。
 

Output
对于每组数据,请在一行里输出最短需要行走的距离。如果不存在从S到T的路线,就输出-1.
 

Sample Input
  
  
3 3 0 1 1 0 2 3 1 2 1 0 2 3 1 0 1 1 1 2
 

Sample Output
  
  
2

-1

#include <cstdio>
#include <cstring>
#include<algorithm>
#include<cmath>
#include<vector>
#include<queue>
using namespace std;

#define EPS 1e-7
#define clr(x) memset(x, 0, sizeof(x))
#define long long ll
#define PI acos(-1.0)

const int INF = 0x3f3f3f3f;
const int MOD=100000000;
const int MAXN = 10000000;
const int dx[] = {1, -1, 0, 0};
const int dy[] = {0, 0, 1, -1};

vector<pair<int, int> > G[1005];
int d[1005];
int main()
{
    int n, m;
    while(~scanf("%d %d", &n, &m))
    {
        for(int i = 0; i < n; i++)
            d[i] = INF;
        for(int i = 0; i < n; i++)
            G[i].clear();
        int a, b, c;
        for(int i = 0; i < m; i++)
        {
            scanf("%d %d %d", &a, &b, &c);
            G[a].push_back(make_pair(b, c));
            G[b].push_back(make_pair(a, c));
        }
        int s, t;
        scanf("%d %d", &s, &t);
        priority_queue<pair<int, int> > pq;   // 默认从大到小
        d[s] = 0;
        pq.push(make_pair(-d[s], s));    // 距离小的,负值就更大
        while(!pq.empty())
        {
            int now = pq.top().second;
            pq.pop();
            for(int i = 0; i < G[now].size(); i++)
            {
                int v = G[now][i].first;
                if(d[v] >  d[now] + G[now][i].second)
                {
                    d[v] = d[now] + G[now][i].second;
                    pq.push(make_pair(-d[v], v));
                }
            }
        }
        if(d[t] == INF)
            printf("-1\n");
        else
            printf("%d\n", d[t]);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值