Piggy-Bank (完全背包)

Before ACM can do anything, a budget must be prepared and the necessary financial support obtained. The main income for this action comes from Irreversibly Bound Money (IBM). The idea behind is simple. Whenever some ACM member has any small money, he takes all the coins and throws them into a piggy-bank. You know that this process is irreversible, the coins cannot be removed without breaking the pig. After a sufficiently long time, there should be enough cash in the piggy-bank to pay everything that needs to be paid.

But there is a big problem with piggy-banks. It is not possible to determine how much money is inside. So we might break the pig into pieces only to find out that there is not enough money. Clearly, we want to avoid this unpleasant situation. The only possibility is to weigh the piggy-bank and try to guess how many coins are inside. Assume that we are able to determine the weight of the pig exactly and that we know the weights of all coins of a given currency. Then there is some minimum amount of money in the piggy-bank that we can guarantee. Your task is to find out this worst case and determine the minimum amount of cash inside the piggy-bank. We need your help. No more prematurely broken pigs!

Input
The input consists of T test cases. The number of them (T) is given on the first line of the input file. Each test case begins with a line containing two integers E and F. They indicate the weight of an empty pig and of the pig filled with coins. Both weights are given in grams. No pig will weigh more than 10 kg, that means 1 <= E <= F <= 10000. On the second line of each test case, there is an integer number N (1 <= N <= 500) that gives the number of various coins used in the given currency. Following this are exactly N lines, each specifying one coin type. These lines contain two integers each, Pand W (1 <= P <= 50000, 1 <= W <=10000). P is the value of the coin in monetary units, W is it's weight in grams.
Output
Print exactly one line of output for each test case. The line must contain the sentence "The minimum amount of money in the piggy-bank is X." where X is the minimum amount of money that can be achieved using coins with the given total weight. If the weight cannot be reached exactly, print a line "This is impossible.".
Sample Input
3
10 110
2
1 1
30 50
10 110
2
1 1
50 30
1 6
2
10 3
20 4
Sample Output
The minimum amount of money in the piggy-bank is 60.
The minimum amount of money in the piggy-bank is 100.
This is impossible.
题意:

一个小猪储蓄罐,里面有一定的硬币,硬币的总重量已知,每种硬币有不同的价值和重量,

求储蓄罐内硬币价值和最少的可能,如果不可能输出“This is impossible.”

思路:

要使价值正好为总价值,每种硬币的数量不唯一,所以是完全背包问题

将dp初始化为无穷大,每次取最小值

dp【j】=min ( dp【j-w【i】】+val【i】,dp【j】)

代码:

#include<stdio.h>
#include<string.h>
#include<algorithm>
#define Inf 0x3f3f3f3f
using namespace std;
int val[505];//硬币价值
int w[505];//硬币重量
int dp[10005];
int main(){
    int T;
    scanf("%d",&T);
    while(T--){
        memset(val,0,sizeof(0));
        memset(w,0,sizeof(w));
        memset(dp,Inf,sizeof(dp));
        int b,a;
        scanf("%d%d",&b,&a);
        a-=b;
        int n;
        scanf("%d",&n);
        int i;
        for(i=1;i<=n;i++)
            scanf("%d%d",&val[i],&w[i]);
        dp[0]=0;
        int j;
        for(i=1;i<=n;i++){
            for(j=w[i];j<=a;j++)
            dp[j]=min(dp[j],dp[j-w[i]]+val[i]);
        }
        if(dp[a]==Inf) printf("This is impossible.\n");
        else printf("The minimum amount of money in the piggy-bank is %d.\n",dp[a]);
    }
return 0;
}
总结:

如果是背包问题,对于要装的物品数目不一定或者无穷,而且要求装满

则一定是完全背包问题

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值