Area of a Parallelogram

A parallelogram is a quadrilateral with two pairs of parallel sides. See the picture below:

Fig: a parallelogram

Now you are given the co ordinates of A, B and C, you have to find the coordinates ofD and the area of the parallelogram. The orientation of ABCD should be same as in the picture.


Input

Input starts with an integer T (≤ 1000), denoting the number of test cases.

Each case starts with a line containing six integers Ax, Ay, Bx, By, Cx, Cy where(Ax, Ay) denotes the coordinate of A, (Bx, By) denotes the coordinate ofB and (Cx, Cy) denotes the coordinate ofC. Value of any coordinate lies in the range [-1000, 1000]. And you can assume thatA, B and C will not be collinear.

Output

For each case, print the case number and three integers where the first two should be the coordinate ofD and the third one should be the area of the parallelogram.

Sample Input

3

0 0 10 0 10 10

0 0 10 0 10 -20

-12 -10 21 21 1 40

Sample Output

Case 1: 0 10 100

Case 2: 0 -20 200

Case 3: -32 9 1247


题目大意:

求D点的坐标以及平行四边形的面积

代码:

#include<stdio.h>
#include<math.h>
using namespace std;

int main(){
	int T;
	scanf("%d",&T);
	int k=0;
	while(T--){
		int x1,y1,x2,y2,x3,y3;
		scanf("%d%d%d%d%d%d",&x1,&y1,&x2,&y2,&x3,&y3);
		double l,h;
		int x4=x3-x2+x1;
		int y4=y3-y2+y1;
		l=sqrt((x1-x2)*(x1-x2)+(y1-y2)*(y1-y2));
		h=(fabs(-(y2-y1)*x3+(x2-x1)*y3-(x2-x1)*y1+(y2-y1)*x1))/sqrt((x2-x1)*(x2-x1)+(y2-y1)*(y2-y1)); 
		printf("Case %d: %d %d %.0f\n",++k,x4,y4,h*l);
	}
	return 0;
}

思路二:

海伦公式:  p=0.5*(s1+s2+s3);
                     S=sqrt(p*(p-s1)*(p-s2)*(p-s3));

                    先求出三角形面积,平行四边形是三角形二倍

代码:

#include<stdio.h>
#include<math.h>
using namespace std;
int main(){
	int T;
	scanf("%d",&T);
	int k=0;
	while(T--){
		int x1,y1,x2,y2,x3,y3;
		scanf("%d%d%d%d%d%d",&x1,&y1,&x2,&y2,&x3,&y3);
		int x4=x3-x2+x1;
		int y4=y3-y2+y1;
		double s1=sqrt((x1-x2)*(x1-x2)+(y1-y2)*(y1-y2));//求边长 
		double s2=sqrt((x1-x3)*(x1-x3)+(y1-y3)*(y1-y3));
		double s3=sqrt((x2-x3)*(x2-x3)+(y2-y3)*(y2-y3));
		double p=0.5*(s1+s2+s3);
		double S=sqrt(p*(p-s1)*(p-s2)*(p-s3));//三角形面积 
		printf("Case %d: %d %d %.0f\n",++k,x4,y4,2*S);
	}
	return 0;
}



评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值