1111 Online Map (30 分)
Input our current position and a destination, an online map can recommend several paths. Now your job is to recommend two paths to your user: one is the shortest, and the other is the fastest. It is guaranteed that a path exists for any request.
Input Specification:
Each input file contains one test case. For each case, the first line gives two positive integers N (2≤N≤500), and M, being the total number of streets intersections on a map, and the number of streets, respectively. Then M lines follow, each describes a street in the format:
V1 V2 one-way length time
where V1 and V2 are the indices (from 0 to N−1) of the two ends of the street; one-way is 1 if the street is one-way from V1 to V2, or 0 if not; length is the length of the street; and time is the time taken to pass the street.
Finally a pair of source and destination is given.
Output Specification:
For each case, first print the shortest path from the source to the destination with distance D in the format:
Distance = D: source -> v1 -> ... -> destination
Then in the next line print the fastest path with total time T:
Time = T: source -> w1 -> ... -> destination
In case the shortest path is not unique, output the fastest one among the shortest paths, which is guaranteed to be unique. In case the fastest path is not unique, output the one that passes through the fewest intersections, which is guaranteed to be unique.
In case the shortest and the fastest paths are identical, print them in one line in the format:
Distance = D; Time = T: source -> u1 -> ... -> destination
Sample Input 1:
10 15
0 1 0 1 1
8 0 0 1 1
4 8 1 1 1
3 4 0 3 2
3 9 1 4 1
0 6 0 1 1
7 5 1 2 1
8 5 1 2 1
2 3 0 2 2
2 1 1 1 1
1 3 0 3 1
1 4 0 1 1
9 7 1 3 1
5 1 0 5 2
6 5 1 1 2
3 5
Sample Output 1:
Distance = 6: 3 -> 4 -> 8 -> 5
Time = 3: 3 -> 1 -> 5
Sample Input 2:
7 9
0 4 1 1 1
1 6 1 1 3
2 6 1 1 1
2 5 1 2 2
3 0 0 1 1
3 1 1 1 3
3 2 1 1 2
4 5 0 2 2
6 5 1 1 2
3 5
Sample Output 2:
Distance = 3; Time = 4: 3 -> 2 -> 5
Code:
#include <iostream>
#include <cstdio>
#include <vector>
#pragma warning(disable:4996)
using namespace std;
const int maxn = 505;
const int INF = 0x3f3f3f3f;
int dis[maxn][maxn], tim[maxn][maxn];
int pre_d[maxn], pre_t[maxn];
int n, m;
int Dijkstra_d(int src, int dst)
{
int d[maxn], ti[maxn];
bool vis[maxn] = { false };
fill(d, d + n, INF);
fill(ti, ti + n, INF);
d[src] = ti[src] = 0;
for (int q = 0; q<n; q++)
{
int v = -1, min_dis = INF;
for (int i = 0; i<n; i++)
{
if (!vis[i] && d[i] < min_dis)
{
v = i;
min_dis = d[i];
}
}
if (v == -1) return -1;
vis[v] = true;
for (int i = 0; i<n; i++)
{
if (!vis[i] && dis[v][i] != INF)
{
if (d[i] > d[v] + dis[v][i])
{
d[i] = d[v] + dis[v][i];
ti[i] = ti[v] + tim[v][i];
pre_d[i] = v;
}
else if (d[i] == d[v] + dis[v][i])
{
if (ti[i] > ti[v] + tim[v][i])
{
ti[i] = ti[v] + tim[v][i];
pre_d[i] = v;
}
}
}
}
}
return d[dst];
}
int Dijkstra_t(int src, int dst)
{
int ti[maxn], num[maxn] = { 0 };
bool vis[maxn] = { false };
fill(ti, ti + n, INF);
ti[src] = 0;
for (int q = 0; q<n; q++)
{
int v = -1, min_time = INF;
for (int i = 0; i<n; i++)
{
if (!vis[i] && ti[i] < min_time)
{
v = i;
min_time = ti[i];
}
}
if (v == -1) return -1;
vis[v] = true;
for (int i = 0; i<n; i++)
{
if (!vis[i] && tim[v][i] != INF)
{
if (ti[i] > ti[v] + tim[v][i])
{
ti[i] = ti[v] + tim[v][i];
num[i] = num[v] + 1;
pre_t[i] = v;
}
else if (ti[i] == ti[v] + tim[v][i])
{
if (num[i] > num[v] + 1)
{
num[i] = num[v] + 1;
pre_t[i] = v;
}
}
}
}
}
return ti[dst];
}
void dfs(int dst, int* pre, vector<int>& result)
{
if (dst == pre[dst])
{
result.push_back(dst);
return;
}
dfs(pre[dst], pre, result);
result.push_back(dst);
}
int main()
{
scanf("%d%d", &n, &m);
fill(dis[0], dis[0] + maxn * maxn, INF);
fill(tim[0], tim[0] + maxn * maxn, INF);
for (int i = 0; i<n; i++)
pre_d[i] = pre_t[i] = i;
for (int i = 0; i<m; i++)
{
int v1, v2, one_way, l, t;
scanf("%d%d%d%d%d", &v1, &v2, &one_way, &l, &t);
dis[v1][v2] = l; tim[v1][v2] = t;
if (!one_way)
{
dis[v2][v1] = l;
tim[v2][v1] = t;
}
}
int src, dst;
scanf("%d%d", &src, &dst);
int min_d = Dijkstra_d(src, dst);
int min_t = Dijkstra_t(src, dst);
vector<int> sh, fa;
dfs(dst, pre_d, sh);
dfs(dst, pre_t, fa);
bool isSame = true;
if (sh.size() != fa.size()) isSame = false;
else
{
for (int i = 0; i<sh.size(); i++)
if (sh[i] != fa[i]) isSame = false;
}
if (isSame)
{
printf("Distance = %d; Time = %d: ", min_d, min_t);
for (int i = 0; i<sh.size(); i++)
printf("%d%s", sh[i], (i == sh.size() - 1 ? "\n" : " -> "));
}
else
{
printf("Distance = %d: ", min_d);
for (int i = 0; i<sh.size(); i++)
printf("%d%s", sh[i], (i == sh.size() - 1 ? "\n" : " -> "));
printf("Time = %d: ", min_t);
for (int i = 0; i<fa.size(); i++)
printf("%d%s", fa[i], (i == fa.size() - 1 ? "\n" : " -> "));
}
return 0;
}