- Family Property (25)
时间限制
150 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue
This time, you are supposed to help us collect the data for family-owned property. Given each person’s family members, and the estate(房产)info under his/her own name, we need to know the size of each family, and the average area and number of sets of their real estate.
Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N (<=1000). Then N lines follow, each gives the infomation of a person who owns estate in the format:
ID Father Mother k Child1 … Childk M_estate Area
where ID is a unique 4-digit identification number for each person; Father and Mother are the ID’s of this person’s parents (if a parent has passed away, -1 will be given instead); k (0<=k<=5) is the number of children of this person; Childi’s are the ID’s of his/her children; M_estate is the total number of sets of the real estate under his/her name; and Area is the total area of his/her estate.
Output Specification:
For each case, first print in a line the number of families (all the people that are related directly or indirectly are considered in the same family). Then output the family info in the format:
ID M AVG_sets AVG_area
where ID is the smallest ID in the family; M is the total number of family members; AVG_sets is the average number of sets of their real estate; and AVG_area is the average area. The average numbers must be accurate up to 3 decimal places. The families must be given in descending order of their average areas, and in ascending order of the ID’s if there is a tie.
Sample Input:
10
6666 5551 5552 1 7777 1 100
1234 5678 9012 1 0002 2 300
8888 -1 -1 0 1 1000
2468 0001 0004 1 2222 1 500
7777 6666 -1 0 2 300
3721 -1 -1 1 2333 2 150
9012 -1 -1 3 1236 1235 1234 1 100
1235 5678 9012 0 1 50
2222 1236 2468 2 6661 6662 1 300
2333 -1 3721 3 6661 6662 6663 1 100
Sample Output:
3
8888 1 1.000 1000.000
0001 15 0.600 100.000
5551 4 0.750 100.000
#include<cstdio>
#include<algorithm>
using namespace std;
const int maxn=10001;
const int maxm=1001;
struct Member{
int n;
double a;
}mem[maxn];
struct Ans{
int id;
int n;
double a;
double avg;
int an;
}ans[maxn];
int family[maxm];
int father[maxn];
int visited[maxn];
int isroot[maxn];
int n;
bool cmp(Ans a,Ans b){
if(a.avg!=b.avg) return a.avg>b.avg;
else return a.id<b.id;
}
int findFather(int x){
int a=x;
while(x!=father[x]){
x=father[x];
}
while(a!=father[a]){
int z=a;
a=father[a];
father[z]=x;
}
return x;
}
void Union(int a,int b){
int faA=findFather(a);
int faB=findFather(b);
if(faA<faB){
father[faB]=faA;
}else father[faA]=faB;
}
int main(){
for(int i=0;i<maxn;i++){
mem[i].n=0;
mem[i].a=0;
father[i]=i;
visited[i]=0;
isroot[i]=0;
ans[i].a=0;
ans[i].avg=0;
ans[i].id=i;
ans[i].n=0;
ans[i].an=0;
}
scanf("%d",&n);
for(int i=0;i<n;i++){
int id;
scanf("%d",&id);
visited[id]=1;
family[i]=id;
int a,b;
scanf("%d %d",&a,&b);
if(a!=-1){
Union(a,findFather(id));
visited[a]=1;
}
if(b!=-1){
Union(b,findFather(id));
visited[b]=1;
}
int k;
scanf("%d",&k);
for(int i=0;i<k;i++){
scanf("%d",&a);
Union(a,findFather(id));
visited[a]=1;
}
scanf("%d %lf",&mem[id].n,&mem[id].a);
//if(mem[id].a!=0)printf("%d %lf\n",mem[id].n,mem[id].a);
}
for(int i=0;i<maxn;i++){
if(visited[i]==1){
int idx=findFather(i);
isroot[idx]++;
ans[idx].n++;
ans[idx].a+=mem[i].a;
ans[idx].an+=mem[i].n;
//if(mem[i].a!=0)printf("idx=%d %d %lf\n",idx,mem[i].n,mem[i].a);
}
}
int cnt=0;
for(int i=0;i<maxn;i++){
if(isroot[i]!=0){
cnt++;
//printf("id=%d %.3f %d\n",i,ans[i].an,ans[i].n);
ans[i].avg=ans[i].a/ans[i].n;
}
}
printf("%d\n",cnt);
sort(ans,ans+maxn,cmp);
for(int i=0;i<cnt;i++)
printf("%04d %d %.3f %.3f\n",ans[i].id,ans[i].n,ans[i].an/(double)ans[i].n,ans[i].a/ans[i].n);
return 0;
}