第三次作业

文章详细描述了在多个路由器(R1-R5)上进行IP配置、静态路由设置、PPP(PAP/CHAP)和HDLC封装,以及MGRE隧道创建的过程,同时涉及RIP路由协议的配置和NAT策略,确保私有网络的全网可达性。
摘要由CSDN通过智能技术生成

1.配置IP

R1:

[R1]int g0/0/0
[R1-GigabitEthernet0/0/0]ip add 192.168.1.1 24
[R1]int Serial 4/0/0
[R1-Serial4/0/0]ip add 15.1.1.1 24

R2:

[R2]int g0/0/0
[R2-GigabitEthernet0/0/0]ip add 192.168.2.2 24
[R2]int Serial 4/0/0
[R2-Serial4/0/0]ip add 25.1.1.2 24

R3:

[R3]int g0/0/0
[R3-GigabitEthernet0/0/0]ip add 192.168.3.3 24
[R3]interface Serial 4/0/0
[R3-Serial4/0/0]ip add 35.1.1.3 24

R4: 

[R4]int g0/0/0
[R4-GigabitEthernet0/0/0]ip add 45.1.1.4 24
[R4]int g0/0/1
[R4-GigabitEthernet0/0/1]ip add 192.168.4.4 24

R5:

[R5]int g0/0/0
[R5-GigabitEthernet0/0/0]ip add 45.1.1.5 24
Mar 30 2024 14:19:18-08:00 R5 %%01IFNET/4/LINK_STATE(l)[0]:The line protocol IP 
on the interface GigabitEthernet0/0/0 has entered the UP state. 
[R5-GigabitEthernet0/0/0]q
[R5]int s 4/0/0
[R5-Serial4/0/0]ip add 35.1.1.5 24
Mar 30 2024 14:19:49-08:00 R5 %%01IFNET/4/LINK_STATE(l)[1]:The line protocol PPP
 IPCP on the interface Serial4/0/0 has entered the UP state. 
[R5-Serial4/0/0]int s 4/0/1
[R5-Serial4/0/1]ip add 15.1.1.5 24
Mar 30 2024 14:20:21-08:00 R5 %%01IFNET/4/LINK_STATE(l)[2]:The line protocol PPP
 IPCP on the interface Serial4/0/1 has entered the UP state. 
[R5-Serial4/0/1]int s 3/0/1
[R5-Serial3/0/1]ip add 25.1.1.5 24
Mar 30 2024 14:20:57-08:00 R5 %%01IFNET/4/LINK_STATE(l)[3]:The line protocol PPP
 IPCP on the interface Serial3/0/1 has entered the UP state. 
[R5-Serial3/0/1]q	
[R5]int LoopBack 0
[R5-LoopBack0]ip add 5.5.5.5 24

2.配置静态路由

 R1:

[R1]ip ro	
[R1]ip route-	
[R1]ip route-static 0.0.0.0 0 15.1.1.5
[R1]ip ro	
[R1]ip route-	
[R1]ip route-static 0.0.0.0 0 25.1.1.5
[R1]ip ro	
[R1]ip route-	
[R1]ip route-static 0.0.0.0 0 35.1.1.5
[R1]ip ro	
[R1]ip route-	
[R1]ip route-static 0.0.0.0 0 45.1.1.5

3.R1,R5之间使用ppp的pap协议认证R5为主认证方

[R5]aaa
[R5-aaa]lo	
[R5-aaa]local-user r15 pass	
[R5-aaa]local-user r15 password ci	
[R5-aaa]local-user r15 password cipher r15
Info: Add a new user.
[R5-aaa]lo	
[R5-aaa]local-user r15 ser	
[R5-aaa]local-user r15 service-type ppp
[R5-aaa]int s4/0/1
[R5-Serial4/0/1]link	
[R5-Serial4/0/1]link-protocol ppp
[R5-Serial4/0/1]ppp au	
[R5-Serial4/0/1]ppp authentication-mode pap

[R1]int S4/0/0
[R1-Serial4/0/0]link	
[R1-Serial4/0/0]link-protocol ppp
[R1-Serial4/0/0]ppp pap lo	
[R1-Serial4/0/0]ppp pap local-user r15 pas	
[R1-Serial4/0/0]ppp pap local-user r15 password ci	
[R1-Serial4/0/0]ppp pap local-user r15 password cipher r15

4.R2,R5之间使用ppp的CHAP认证,R5为主认证方

[R5]aaa
[R5-aaa]lo	
[R5-aaa]local-user r25 pas	
[R5-aaa]local-user r25 password ci	
[R5-aaa]local-user r25 password cipher r25
Info: Add a new user.
[R5-aaa]lo	
[R5-aaa]local-user r25 ser	
[R5-aaa]local-user r25 service-type ppp
[R5-aaa]int s3/0/1
[R5-Serial3/0/1]ppp au	
[R5-Serial3/0/1]ppp authentication-mode ch	
[R5-Serial3/0/1]ppp authentication-mode chap
[R5-Serial3/0/1]link	
[R5-Serial3/0/1]link-protocol ppp
[R2]int s4/0/0
[R2-Serial4/0/0]ppp ch	
[R2-Serial4/0/0]ppp chap u	
[R2-Serial4/0/0]ppp chap user r25
[R2-Serial4/0/0]ppp ch	
[R2-Serial4/0/0]ppp chap pa	
[R2-Serial4/0/0]ppp chap password ci	
[R2-Serial4/0/0]ppp chap password cipher r25

5.R3,R5之间使用HDLC封装

[R3]int s4/0/0
[R3-Serial4/0/0]lin	
[R3-Serial4/0/0]link-protocol hdlc
Warning: The encapsulation protocol of the link will be changed. Continue? [Y/N]
:y
Mar 30 2024 14:38:00-08:00 R3 %%01IFNET/4/CHANGE_ENCAP(l)[0]:The user performed 
the configuration that will change the encapsulation protocol of the link and th
en selected Y. 
[R5]int s4/0/0
[R5-Serial4/0/0]lin	
[R5-Serial4/0/0]link-protocol hdlc
Warning: The encapsulation protocol of the link will be changed. Continue? [Y/N]
:y
Mar 30 2024 14:39:05-08:00 R5 %%01IFNET/4/CHANGE_ENCAP(l)[2]:The user performed 
the configuration that will change the encapsulation protocol of the link and th
en selected Y. 

6.R1,R2,R3构建一个MGRE环节,R1为中心站点,R1,R4间为点到点的GRE

[R1]int t0/0/0
[R1-Tunnel0/0/0]ip add 10.1.1.1 24
[R1-Tunnel0/0/0]tun	
[R1-Tunnel0/0/0]tunnel-protocol gre p2mp
[R1-Tunnel0/0/0]so	
[R1-Tunnel0/0/0]source 15.1.1.1
Mar 30 2024 14:42:44-08:00 R1 %%01IFNET/4/LINK_STATE(l)[0]:The line protocol IP 
on the interface Tunnel0/0/0 has entered the UP state. 
[R1-Tunnel0/0/0]
[R1-Tunnel0/0/0]nhrp ne	
[R1-Tunnel0/0/0]nhrp network-id 100
[R1-Tunnel0/0/0]nhrp en	
[R1-Tunnel0/0/0]nhrp entry mu	
[R1-Tunnel0/0/0]nhrp entry multicast dy	
[R1-Tunnel0/0/0]nhrp entry multicast dynamic 
[R2]int t0/0/0
[R2-Tunnel0/0/0]ip add 10.1.1.2 24
[R2-Tunnel0/0/0]tun	
[R2-Tunnel0/0/0]tunnel-protocol gre	
[R2-Tunnel0/0/0]tunnel-protocol gre p2mp
[R2-Tunnel0/0/0]so	
[R2-Tunnel0/0/0]source s4/0/0
Mar 30 2024 14:45:00-08:00 R2 %%01IFNET/4/LINK_STATE(l)[0]:The line protocol IP 
on the interface Tunnel0/0/0 has entered the UP state. 
[R2-Tunnel0/0/0]
[R2-Tunnel0/0/0]nhrp ne	
[R2-Tunnel0/0/0]nhrp network-id 100
[R2-Tunnel0/0/0]nhrp entry 10.1.1.1 15.1.1.1 register

 

[R3]int t0/0/0
[R3-Tunnel0/0/0]ip add 10.1.1.3 24
[R3-Tunnel0/0/0]tun	
[R3-Tunnel0/0/0]tunnel-protocol gre p2mp
[R3-Tunnel0/0/0]so	
[R3-Tunnel0/0/0]source s4/0/0
Mar 30 2024 14:47:43-08:00 R3 %%01IFNET/4/LINK_STATE(l)[0]:The line protocol IP 
on the interface Tunnel0/0/0 has entered the UP state. 
[R3-Tunnel0/0/0]
[R3-Tunnel0/0/0]nhrp ne	
[R3-Tunnel0/0/0]nhrp network-id 100
[R3-Tunnel0/0/0]nhrp en	
[R3-Tunnel0/0/0]nhrp entry 10.1.1.1 15.1.1.1 re	
[R3-Tunnel0/0/0]nhrp entry 10.1.1.1 15.1.1.1 register 
[R1]int t0/0/1
[R1-Tunnel0/0/1]ip add 10.1.2.1 24
[R1-Tunnel0/0/1]tun	
[R1-Tunnel0/0/1]tunnel-protocol gre	
[R1-Tunnel0/0/1]sou	
[R1-Tunnel0/0/1]source 15.1.1.1
[R1-Tunnel0/0/1]des	
[R1-Tunnel0/0/1]description
[R1-Tunnel0/0/1]destination 45.1.1.4
[R4]int t0/0/1
[R4-Tunnel0/0/1]ip add 10.1.2.2 24
[R4-Tunnel0/0/1]tun	
[R4-Tunnel0/0/1]tunnel-protocol gre
[R4-Tunnel0/0/1]sou	
[R4-Tunnel0/0/1]source 45.1.1.4
[R4-Tunnel0/0/1]des	
[R4-Tunnel0/0/1]description
[R4-Tunnel0/0/1]destination 15.1.1.1

 7.整个私有网络基本RIP全网可达

[R1]rip 1
[R1-rip-1]undo su	
[R1-rip-1]undo summary 
[R1-rip-1]v 2
[R1-rip-1]ne	
[R1-rip-1]network  192.168.1.0
[R1-rip-1]ne	
[R1-rip-1]network 10.0.0.0
[R2]rip 1
[R2-rip-1]undo su	
[R2-rip-1]undo summary 
[R2-rip-1]v 2
[R2-rip-1]net	
[R2-rip-1]network 192.168.2.0
[R2-rip-1]ne	
[R2-rip-1]network 10.0.0.0
[R3]rip 1
[R3-rip-1]undo su	
[R3-rip-1]undo summary 
[R3-rip-1]v 2
[R3-rip-1]ne	
[R3-rip-1]network 192.168.3.0
[R3-rip-1]net	
[R3-rip-1]network 10.0.0.0
[R4]rip 1
[R4-rip-1]undo su	
[R4-rip-1]undo summary 
[R4-rip-1]v 2
[R4-rip-1]net	
[R4-rip-1]network 192.168.4.0
[R4-rip-1]ne	
[R4-rip-1]network 10.0.0.0

 取消rip的水平分割机制

[R1]int t0/0/0
[R1-Tunnel0/0/0]undo rip sp	
[R1-Tunnel0/0/0]undo rip split-horizon 

8.所有pc设置私有IP为源IP,可以访问R5环回,达到全网通

pc1:

pc2:

pc3:

pc4: 

配置nat

[R1]acl 2000
[R1-acl-basic-2000]rule pe	
[R1-acl-basic-2000]rule permit so	
[R1-acl-basic-2000]rule permit source 192.168.1.0 0.0.0.255
[R1-acl-basic-2000]int s4/0/0
[R1-Serial4/0/0]nat out	
[R1-Serial4/0/0]nat outbound 2000



[R2]acl 2000
[R2-acl-basic-2000]ru	
[R2-acl-basic-2000]rule per	
[R2-acl-basic-2000]rule permit so	
[R2-acl-basic-2000]rule permit source 192.168.2.0 0.0.0.255
[R2-acl-basic-2000]int s4/0/0
[R2-Serial4/0/0]nat ou	
[R2-Serial4/0/0]nat outbound 2000




[R3]acl 2000
[R3-acl-basic-2000]ru	
[R3-acl-basic-2000]rule per	
[R3-acl-basic-2000]rule permit so	
[R3-acl-basic-2000]rule permit source 192.168.3.0 0.0.0.255
[R3-acl-basic-2000]int s4/0/0
[R3-Serial4/0/0]nat ou	
[R3-Serial4/0/0]nat outbound 2000



[R4]acl 2000
[R4-acl-basic-2000]ru	
[R4-acl-basic-2000]rule per	
[R4-acl-basic-2000]rule permit so	
[R4-acl-basic-2000]rule permit source 192.168.4.0 0.0.0.255
[R4]int g0/0/0
[R4-GigabitEthernet0/0/0]nat ou	
[R4-GigabitEthernet0/0/0]nat outbound 2000

 完成测试:

  • 3
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值