Light Bulb

B. Light Bulb

Time Limit:   1000ms
Memory Limit:   32768KB
64-bit integer IO format:   %lld       Java class name:   Main

Compared to wildleopard's wealthiness, his brother mildleopard is rather poor. His house is narrow and he has only one light bulb in his house. Every night, he is wandering in his incommodious house, thinking of how to earn more money. One day, he found that the length of his shadow was changing from time to time while walking between the light bulb and the wall of his house. A sudden thought ran through his mind and he wanted to know the maximum length of his shadow.

Input

The first line of the input contains an integer T (T <= 100), indicating the number of cases.

Each test case contains three real numbers Hh and D in one line. H is the height of the light bulb while h is the height of mildleopard. D is distance between the light bulb and the wall. All numbers are in range from 10-2 to 103, both inclusive, and H - h >= 10-2.

Output

For each test case, output the maximum length of mildleopard's shadow in one line, accurate up to three decimal places..

Sample Input

3
2 1 0.5
2 0.5 3
4 3 4

Sample Output

1.000
0.750
4.000
ac代码
知识点 : 对号函数的应用,相信这个都会,不会自己百度;
设 灯到墙的距离为下;
数学变换得到 H+d-(x+D*(H-d)/x;
简单数学模拟就可以,
up英语不好,开始没理解题意一直没找到解决办法,
between the light bulb and the wall of his house //意思,影子要在墙上地上都有;
#include<iostream>
#include<cstdio>
#include<cmath>
#include<cstring>
#include<string>
#include<algorithm>
#include<stack>
#include<queue>
using namespace std;
int main()
{
 //std::ios::sync_with_stdio(false);
 int t;
 while (cin>>t)
 {
  while (t--)
  {
   double H, h, D;
   cin >> H >> h >> D;
   double x0 = D*(H - h) / H;
   double x1 = sqrt(D*(H - h));
   double x2 = D;
   double x;
   if (x1 >= x0&&x1 <= x2)  x = x1;
   else if (x1 <= x0)    x = x0;
   else if (x1 >= x2) x = x2;
   printf("%.3lf\n", H + D - x - D*(H - h) / x);
  }
 }
 return 0;
}
 
 
 
 
 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值