ZOJ 3203 Light Bulb 基本不等式

Light Bulb

Time Limit: 1 Second       Memory Limit: 32768 KB

Compared to wildleopard's wealthiness, his brother mildleopard is rather poor. His house is narrow and he has only one light bulb in his house. Every night, he is wandering in his incommodious house, thinking of how to earn more money. One day, he found that the length of his shadow was changing from time to time while walking between the light bulb and the wall of his house. A sudden thought ran through his mind and he wanted to know the maximum length of his shadow.

Input

The first line of the input contains an integer T (T <= 100), indicating the number of cases.

Each test case contains three real numbers Hh and D in one line. H is the height of the light bulb while h is the height of mildleopard. D is distance between the light bulb and the wall. All numbers are in range from 10-2 to 103, both inclusive, and H - h >= 10-2.

Output

For each test case, output the maximum length of mildleopard's shadow in one line, accurate up to three decimal places..

Sample Input

3
2 1 0.5
2 0.5 3
4 3 4

Sample Output

1.000
0.750
4.000

题目意思是让我们求在灯泡的照射下,人在地上的影子和在墙上的影子总长度最长的L。

解题思路:设地上影子长度为x,墙上影子长度为y,利用相似三角形法则,不难得出一个L的一个表达式,L = y + (h-y)*D / (H-y),而通过变形则可以得到D+H-(H-y+(H-h)/(H-y)),然后用基本不等式就不难得出答案了,需要注意的是边界情况不能取到,墙上的影子长度不可能大于h,也不可能出现负值。

代码实现:

#include<bits/stdc++.h>
using namespace std;

int main()
{
	int T;
	cin>>T;
	double H,h,D,x,y;
	while(T--)
	{
		cin>>H>>h>>D;
		y = H - sqrt(D*(H-h));
		if(y > h)	y = h;//边界值特殊处理 
		if(y < 0)	y = 0;
		x = (h-y)/(H-y)*D;
		printf("%.3f\n",x+y);
	}
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值