poj_2406_kmp_入门_精华操作_解释

kmp 得精华就是next数组;
很多博客瞎几把写,误人子弟,
1.还是年轻,很多灌水博客就是这样出现的吧,我遇见过几个大佬,他们一般写博客要么只发代码,要么很严谨,当然很重要的一点是简洁,的语言精确的描述,
2,还有就是刚写博客的小白,这个…..我也是过来人,感觉这个还是自己申明一下,毕竟不成熟.
3.就是培训班的老师,这部分我不想多说,要么很强,想靠算法培训快速赚钱,要么就是水的一比,长篇大论说的不知所云,有技术含量的水这是真的烦;
好来说kmp;
kmp实现原理,我之前转的
next数组: 记录长度为i时子串的前缀和后缀最长相同部分
next数组的实现 ,看代码解释和那个图片
Power Strings
Given two strings a and b we define a*b to be their concatenation. For example, if a = “abc” and b = “def” then a*b = “abcdef”. If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined in the normal way: a^0 = “” (the empty string) and a^(n+1) = a*(a^n).
Input
Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.
Output
For each s you should print the largest n such that s = a^n for some string a.
Sample Input
abcd
aaaa
ababab
.
Sample Output
1
4
3
Hint
This problem has huge input, use scanf instead of cin to avoid time limit exceed.
题意:
给你字符串找能全有由它的子串构成的子串的最小长度

这里写图片描述

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
const int N=1000005;
char s[N];
int next[N];
void getnext()
{
    // i 代表当前串的长度,j最长公共部分
    int len=strlen(s);
    int i=0,j=-1;
    next[0]=j;
    while(i<len)
    {
        if(s[i]==s[j]||j==-1)
        {
            i++;
            j++;
            next[i]=j;
        }
        else j=next[j];
        //当前缀后缀不同时,从长度为j子串公共部分接着匹配
    }
}
int main()
{
    while(~scanf("%s",s) && s[0]!='.')
    {
        getnext();
        int len=strlen(s);
        if(len%(len-next[len])==0)
            cout<<len/(len-next[len])<<endl;
        else puts("1");
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值