VJ组队赛->Chip Factory(5536)

Problem Description
John is a manager of a CPU chip factory, the factory produces lots of chips everyday. To manage large amounts of products, every processor has a serial number. More specifically, the factory produces n chips today, the i -th chip produced this day has a serial number si .

At the end of the day, he packages all the chips produced this day, and send it to wholesalers. More specially, he writes a checksum number on the package, this checksum is defined as below:
maxi,j,k(si+sj)sk

which i,j,k are three different integers between 1 and n . And is symbol of bitwise XOR.

Can you help John calculate the checksum number of today?

Input
The first line of input contains an integer T indicating the total number of test cases.

The first line of each test case is an integer n , indicating the number of chips produced today. The next line has n integers s1,s2,..,sn , separated with single space, indicating serial number of each chip.

1T1000
3n1000
0si109
There are at most 10 testcases with n>100

Output
For each test case, please output an integer indicating the checksum number in a line.
 
Sample Input
  
  
2 3 1 2 3 3 100 200 300

Sample Output
  
  
6 400
题目大意:说了那么多废话,就是求max((a[i]+a[j])^a[k]),其中i,j,k都不相等
看到XOR这个运算符号,我直接是懵的,这是什么呀(@_@),然后队长告诉我是位运算符异或^,不过我感觉题目有点模糊啊,那个max后面不应该加个括号么...
暴力解决吧,本来担心会超时,当我看到时间限制9s后就放心了,23333
#include <iostream>
#include <cstdio>

using namespace std;

const int N = 1e3 + 5;

int main()
{
	int a[N];
	int t,n;
	cin >> t;
	while(t--)
	{
		cin >> n;
		for(int i = 0; i < n; i++)
			scanf("%d",&a[i]);
		int i,j,k;
		int maxn = 0;
		for(i = 0; i < n-2; i++)
		{
			for(j = i+1; j < n-1; j++)
			{
				for(k = j+1; k < n; k++)
				{
					maxn = max(maxn,(a[j]+a[k])^a[i]);
					maxn = max(maxn,(a[i]+a[k])^a[j]);
					maxn = max(maxn,(a[i]+a[j])^a[k]);
				}
			}
		}
		cout << maxn << "\n";
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
#include <stdio.h> #include <stdlib.h> 访问标志向量是全局量 void DFSTraverse(ALGraph *G) { //深度优先遍历以邻接表表示的图 G,而以邻接矩阵表示 G 时,算法完全与 int i; for(i=0;i<G->n;i++) visited[i]=FALSE; //标志向量初始化 for(i=0;i<G->n;i++) if(!visited[i]) //vi 未访问过 DFS(G,i); //以 vi 为源点开始 DFS 此相同 搜索 }//DFSTraverse //(2)邻接表表示的深度优先搜索算法 void DFS(ALGraph *G,int i){ //以 vi 为出发点对邻接表表示的图 G 进行深度优先搜索 EdgeNode *p; printf("visit vertex:%c",G->adjlist[i].vertex);//访问顶点 vi visited[i]=TRUE; //标记 vi 已访问 p=G->adjlist[i].firstedge; //取 vi 边表的头指针 while(p){//依次搜索 vi 的邻接点 vj,这里 j=p->adjvex if (!visited[p->adjvex])//若 vi 尚未被访问 DFS(G,p->adjvex);//则以 Vj 为出发点向纵深搜索 p=p->next; //找 vi 的下一邻接点 } }//DFS #define MaxVertexNum 5 #define m 5 #define NULL 0 typedef struct node { int adjvex; struct node *next; }JD; typedef struct tnode { int vexdata; JD *firstarc; }TD; typedef struct { TD ag[m]; int n; }ALGRAPH; void DFS(ALGRAPH *G,int i); void creat(ALGRAPH *G) {int i,m1,j; JD *p,*p1; printf("please input the number of graph\n"); scanf("%d",&G->n); for(i=0;i<G->n;i++) {printf("please input the info of node %d",i); scanf("%d",&G->ag[i].vexdata); printf("please input the number of arcs which adj to %d",i); scanf("%d",&m1); printf("please input the adjvex position of the first arc\n"); p=(JD *)malloc(sizeof(JD)); scanf("%d",&p->adjvex); p->next=NULL; G->ag[i].firstarc=p; p1=p; for(j=2 ;j<=m1;j++) {printf("please input the position of the next arc vexdata\n"); p=(JD *)malloc(sizeof(JD)); scanf("%d",&p->adjvex); p->next=NULL; p1->next=p; p1=p;} } } int visited[MaxVertexNum]; void DFSTraverse(ALGRAPH *G) { int i; for(i=0;i<G->n;i++) visited[i]=0; for(i=0;i<G->n;i++) if(!visited[i]) DFS(G,i); }/*DFSTraverse */ void DFS(ALGRAPH *G,int i){ JD *p; printf("visit vertex:%d->",G->ag[i].vexdata); visited[i]=1; /*标记 vi 已访问 */ p=G->ag[i].firstarc; /*取 vi 边表的头指针*/ while(p){/*依次搜索 vi 的邻接点 vj,这里 j=p->adjvex*/ if (!visited[p->adjvex])/*若 vi 尚未被访问 */ DFS(G,p->adjvex);/*则以 Vj 为出发点向纵深搜索 */ p=p->next; } }/*DFS */ main() { ALGRAPH *G; printf("下面以临接表存储一个图;\n"); creat(G); printf("下面以深度优先遍历该图 \n"); DFSTraverse(G); getch(); }
最新发布
06-10
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值