Power Strings next数组应用

7 篇文章 0 订阅
Given two strings a and b we define a*b to be their concatenation. For example, if a = "abc" and b = "def" then a*b = "abcdef". If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined in the normal way: a^0 = "" (the empty string) and a^(n+1) = a*(a^n).

Input

Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.

Output

For each s you should print the largest n such that s = a^n for some string a.

Sample Input

abcd
aaaa
ababab
.

Sample Output

1
4
3


题目大意:字符串s由串a连续组合在一起形成,即a^n = s,求n的最大值

next数组又要出场了,对于next[len]表示字符串前后匹配的长度,n - next[len]即为重叠字符串(a)的长度,所以再除len即得到了次数n;否则即为整个字符串s,n = 1

#include <iostream>
#include <algorithm>
#include <cstring>
#include <cstdio>

using namespace std;
const int N = 1e6 + 3;

char s[N];
int next[N];

void GetNext()
{
    int j = -1, len = strlen(s);
    next[0] = -1;
    for(int i = 1; i < len; i++)
    {
        while(j != -1 && s[j + 1] != s[i])
            j = next[j];
        if(s[j + 1] == s[i]) j++;
        next[i] = j;
    }
}
int main()
{
    while(~scanf("%s", s))
    {
        if(s[0] == '.') break;
        GetNext();
        int len = strlen(s);
        if(len % (len - next[len - 1] - 1) == 0)
            printf("%d\n", len / (len - next[len - 1] - 1));
        else
            printf("1\n");
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值