Count the string next数组+DP

7 篇文章 0 订阅

It is well known that AekdyCoin is good at string problems as well as number theory problems. When given a string s, we can write down all the non-empty prefixes of this string. For example:
s: "abab"
The prefixes are: "a", "ab", "aba", "abab"
For each prefix, we can count the times it matches in s. So we can see that prefix "a" matches twice, "ab" matches twice too, "aba" matches once, and "abab" matches once. Now you are asked to calculate the sum of the match times for all the prefixes. For "abab", it is 2 + 2 + 1 + 1 = 6.
The answer may be very large, so output the answer mod 10007.
 
Input
The first line is a single integer T, indicating the number of test cases.
For each case, the first line is an integer n (1 <= n <= 200000), which is the length of string s. A line follows giving the string s. The characters in the strings are all lower-case letters.
 
Output
For each case, output only one number: the sum of the match times for all the prefixes of s mod 10007.

Sample Input
  
  
1 4 abab
 
Sample Output
  
  
6

next数组就罢了,还有dp... 

题目大意:求字符串的所有前缀在字符串中出现的次数之和,既然有前缀,就一定少不了next数组;既然是dp,就一定有状态转移方程:dp[i] = dp[next[i]] + 1

dp[i]表示以s[i]为结尾的前缀出现的次数,由于next[i]表示s[0] ~ s[i]中最长相等前后缀的长度,所以在s[0] ~ s[i]中一定会出现一次s[0] ~ s[next[i]] (前提是next[i] != -1)也就是说一个前缀如果重复出现,那它一定会出现在后面的前缀中,至于+1是加的s[0] ~ s[i]本身

#include <iostream>
#include <algorithm>
#include <cstring>
#include <cstdio>

using namespace std;
const int N = 2e5 + 3;

char s[N];
int n, next[N], dp[N];

void GetNext()
{
    int j = -1;
    next[0] = -1;
    for(int i = 1; i < n; i++)
    {
        while(j != -1 && s[j + 1] != s[i])
            j = next[j];
        if(s[j + 1] == s[i]) j++;
        next[i] = j;
    }
}
int main()
{
    int t;
    scanf("%d", &t);
    while(t--)
    {
        scanf("%d%s", &n, s);
        GetNext();
        int cnt = 0;
        memset(dp, 0, sizeof(0));
        for(int i = 0; i < n; i++)
        {
            if(next[i] != -1)
                dp[i] = (dp[next[i]] + 1) % 10007;
            else
                dp[i] = 1;
            cnt = (cnt + dp[i]) % 10007;
        }
        printf("%d\n", cnt);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值