HDU 5924 Mr. Frog’s Problem

Problem Description

One day, you, a clever boy, feel bored in your math class, and then fall asleep without your control. In your dream, you meet Mr. Frog, an elder man. He has a problem for you.

He gives you two positive integers A and B, and your task is to find all pairs of integers (C, D), such that A≤C≤B,A≤D≤B and A/B+B/A≤C/D+D/C

Input

first line contains only one integer T (T≤125), which indicates the number of test cases. Each test case contains two integers A and B (1≤A≤B≤1018).

Output

For each test case, first output one line “Case #x:”, where x is the case number (starting from 1).

Then in a new line, print an integer s indicating the number of pairs you find.

In each of the following s lines, print a pair of integers C and D. pairs should be sorted by C, and then by D in ascending order.

Sample Input

2
10 10
9 27

Sample Output

Case #1:
1
10 10
Case #2:
2
9 27
27 9

题目大意:

输入一个数n表示接下来有n组测试数据,输入两个数A,B,求A≤C≤B,A≤D≤B,且A/B+B/A≤C/D+D/C;由于A,B是区间的两个端点,所以A/B + B/A 已经就是最大值了。所以当A==B 时答案就是A,B;当不相等时,答案为A,B和B,A;这道题只需注意因为A,B过大需用字符串存储即可。

C++

#include<iostream>
#include<cstdio>
#include<string>
using namespace std;
int main()
{
    int a,d,e,f;
    string b,c;
    scanf("%d",&a);
    e=1;
    while(a--)
    {
        cin>>b>>c;
        if(b==c)
        {
            cout<<"Case #"<<e<<":"<<endl;
            cout<<"1"<<endl;
            cout<<b<<" "<<c<<endl;
            e++;
        }
        else
        {
            cout<<"Case #"<<e<<":"<<endl;
            cout<<"2"<<endl;
            cout<<b<<" "<<c<<endl;
            cout<<c<<" "<<b<<endl;
            e++;
        }
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值