NYOJ 349 Sorting It All Out

Sorting It All Out

时间限制: 3000 ms  |  内存限制: 65535 KB
难度: 3
描述
An ascending sorted sequence of distinct values is one in which some form of a less-than operator is used to order the elements from smallest to largest. For example, the sorted sequence A, B, C, D implies that A < B, B < C and C < D. in this problem, we will give you a set of relations of the form A < B and ask you to determine whether a sorted order has been specified or not.
输入
Input consists of multiple problem instances. Each instance starts with a line containing two positive integers n and m. the first value indicated the number of objects to sort, where 2 <= n <= 26. The objects to be sorted will be the first n characters of the uppercase alphabet. The second value m indicates the number of relations of the form A < B which will be given in this problem instance. Next will be m lines, each containing one such relation consisting of three characters: an uppercase letter, the character "<" and a second uppercase letter. No letter will be outside the range of the first n letters of the alphabet. Values of n = m = 0 indicate end of input.
输出
For each problem instance, output consists of one line. This line should be one of the following three: 

Sorted sequence determined after xxx relations: yyy...y. 
Sorted sequence cannot be determined. 
Inconsistency found after xxx relations. 

where xxx is the number of relations processed at the time either a sorted sequence is determined or an inconsistency is found, whichever comes first, and yyy...y is the sorted, ascending sequence. 

样例输入
4 6
A<B
A<C
B<C
C<D
B<D
A<B
3 2
A<B
B<A
26 1
A<Z
0 0

样例输出
Sorted sequence determined after 4 relations: ABCD.
Inconsistency found after 2 relations.
Sorted sequence cannot be determined.
来源
POJ
上传者

陈玉


#include<iostream>
#include<cstring>
#include<cstdio>
#include<cmath>
#include<vector>
#include<algorithm>
using namespace std;
#define s 120
#define s 120
#define inf 0x3f3f3f3f
int n,m,indegree[s],vis[s],tmp[s],rel[s][s];
char c[4],ans[s];
int toposort(){
	int i,j,zero,k,flag=1;
	memcpy(tmp,indegree,sizeof(tmp));
	memset(ans, '\0', sizeof(ans));  
    for (i = 0; i < n; i++)  
    {  
        zero = 0;//入度为0的点的个数  
        for (j = 0; j < n; j++){  
            if (tmp[j] == 0){  
                k = j;//下标  
                zero++;  
            }  
        }  
        if (zero == 0) return -1;//有环   
        if (zero>1)  flag = 0;//无序(还不能确定是否有环, 所以继续)  
        else    ans[i] = 'A' + k;  
        tmp[k]--;
        for (j = 0; j < n; j++){  
            if (rel[k][j])//由此点出发能直达的点入度减 1  
                tmp[j]--;  
        }  
    }
    return flag;
} 

int main(){
	int i,j,k;
	while(~scanf("%d%d",&n,&m)&&n+m){
		bool sure=false;
		memset(rel,0,sizeof(rel));
		memset(indegree,0,sizeof(indegree));
		for(i=1;i<=m;i++){
			scanf("%s",&c);
			if(sure) continue;
			if(!rel[c[0]-'A'][c[2]-'A']){
				rel[c[0]-'A'][c[2]-'A']=1;
				indegree[c[2]-'A']++;
			}//判重 
			int res=toposort();
			if(res==1){
				sure=true;
				printf("Sorted sequence determined after %d relations: %s.\n", i, ans);
			}
			else if(res==-1){
				sure=true;
				printf("Inconsistency found after %d relations.\n", i);
			}
		}
		if(!sure)
			  printf("Sorted sequence cannot be determined.\n"); 
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值