PAT 01-2. Maximum Subsequence Sum (25)

7 篇文章 0 订阅

Given a sequence of K integers { N1, N2, ..., NK }. A continuous subsequence is defined to be { Ni, Ni+1, ..., Nj } where 1 <= i <= j <= K. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.

Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.

Input Specification:

Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K (<= 10000). The second line contains K numbers, separated by a space.

Output Specification:

For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices i and j (as shown by the sample case). If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.

Sample Input:
10
-10 1 2 3 4 -5 -23 3 7 -21
Sample Output:

10 1 4

说明:这个题目内容虽然用英文编写,但是与PAT 01-1是一样的都是求最大子列和,不过本题同时要求输出最大子列的第一个和最后一个元素,同时要注意特殊序列的情况,特别是全零的数列的处理。

/*
问题:最大子列和问题,同时输出最大子列的第一个和最后一个元素
解决方法:在线处理
时间复杂度:O(n)
*/

#include <stdio.h>
#include <malloc.h>

void findSeq(int n,int list[]); //在线处理方式

int main()
{
	int length,i;
	int *list;
	scanf("%d",&length);
	list=(int*)calloc(length,sizeof(int));
	for(i=0;i<length;i++){
		scanf("%d ",&list[i]);
	}
	findSeq(length,list);
	return 0;
}

void findSeq(int n,int list[]){
	int thissum,maxsum=0;
	int first=list[0];
	int last=list[n-1];
	int i,j;
	thissum=0;
	first=list[0];
	for(i=0;i<n;i++){
		thissum+=list[i];
		if(thissum>maxsum){
			maxsum=thissum;
			j=i;
			last=list[i];
		}
		else 
			if(thissum<0){
				thissum=0;
			}
	}
	if(maxsum>0){
		thissum=0;
		while(thissum!=maxsum){
			thissum+=list[j--];
		}
		j++;
		first=list[j];
	}
	else{
		for(i=0;i<n;i++){
			if(list[i]==0){
				first=last=list[i];
				break;
			}
		}
	}
	printf("%d %d %d",maxsum,first,last);
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值