甲级PAT 1060 Are They Equal (25 分)(科学表示法)

1060 Are They Equal (25 分)

If a machine can save only 3 significant digits, the float numbers 12300 and 12358.9 are considered equal since they are both saved as 0.123×10​5​​ with simple chopping. Now given the number of significant digits on a machine and two float numbers, you are supposed to tell if they are treated equal in that machine.

Input Specification:

Each input file contains one test case which gives three numbers N, A and B, where N (<100) is the number of significant digits, and A and B are the two float numbers to be compared. Each float number is non-negative, no greater than 10​100​​, and that its total digit number is less than 100.

Output Specification:

For each test case, print in a line YES if the two numbers are treated equal, and then the number in the standard form 0.d[1]...d[N]*10^k (d[1]>0 unless the number is 0); or NOif they are not treated equal, and then the two numbers in their standard form. All the terms must be separated by a space, with no extra space at the end of a line.

Note: Simple chopping is assumed without rounding.

Sample Input 1:

3 12300 12358.9

Sample Output 1:

YES 0.123*10^5

Sample Input 2:

3 120 128

Sample Output 2:

NO 0.120*10^3 0.128*10^3

题目说明以后补。

完整代码 

#include<bits/stdc++.h>
using namespace std;

int main(){
	int n,i,p=0,q=0,aindex,bindex;
	char a[10050],b[10050],A[10050],B[10050];
	scanf("%d%s%s",&n,a,b);
	int alen=strlen(a);
	int blen=strlen(b);
	int apoint=alen;
	int bpoint=blen;
	for(i=0;i<alen;i++){
		if(a[i]=='.'){
			apoint=i;
			break;
		}
	}
	for(i=0;i<blen;i++){
		if(b[i]=='.'){
			bpoint=i;
			break;
		}
	}
	while(a[p]=='0'||a[p]=='.') p++;
	while(b[q]=='0'||b[q]=='.') q++;
	if(apoint>=p) aindex=apoint-p;
	else aindex=apoint-p+1;
	if(bpoint>=q) bindex=bpoint-q;
	else bindex=bpoint-q+1;
	if(p==alen) aindex=0;
	if(q==blen) bindex=0;
	int atemp=0,btemp=0;
	while(atemp<n){
		if(p>=alen) A[atemp++]='0';
		else if(a[p]!='.') A[atemp++]=a[p];
		p++;
	}
	while(btemp<n){
		if(q>=blen) B[btemp++]='0';
		else if(b[q]!='.') B[btemp++]=b[q];
		q++;
	}
	if(strcmp(A,B)==0 && aindex==bindex) printf("YES 0.%s*10^%d",A,aindex);
	else printf("NO 0.%s*10^%d 0.%s*10^%d",A,aindex,B,bindex);
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值