1146 -- 结义兄弟

结义兄弟

Time Limit:1000MS  Memory Limit:65536K
Total Submit:102 Accepted:84

Description

古人结义,年长为兄,年幼为弟。某日我校某班同学打算结义气兄弟,但他们遇到了一个难题:谁为兄,谁为弟呢?

Input

输入第一行有一个整数N(0< N < 1000)表示N个同学。
接下来有N行,且每行都有一个字符串(全为小写字母且长度小于30)和3个整数 ,分别表示姓名、年、月、日。
所有同学的年龄均为1900年以后的。

Output

请按从兄到弟的顺序输出所有同学的姓名。
假设不存在同年同月同日生的同学。

Sample Input

4
zhangsan 2000 7 8
lisi 2000 5 2
wanger 2001 5 1
mazi 2000 5 1

Sample Output

mazi 
lisi 
zhangsan 
wanger 

Hint

ahstu@icpc2014

Source

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;

namespace AK1146 {
    class Program {
        struct People {
            public string name;
            public int year , month , day;
        }
        public class MyComparer : IComparer<People> {
            int IComparer<People>.Compare(People a , People b) {
                if (a.year == b.year) {
                    if (a.month == b.month)
                        return a.day < b.day ? -1 : 1;
                    return a.month < b.month ? -1 : 1;
                }
                return a.year < b.year ? -1 : 1;
            }
        }
        static void Main(string[] args) {
            int n = int.Parse(Console.ReadLine());
            People[] p = new People[n + 5];
            for (int i = 0 ; i < n ; i++) {
                string[] s = Console.ReadLine().Split();
                p[i].name = s[0];
                p[i].year = int.Parse(s[1]);
                p[i].month = int.Parse(s[2]);
                p[i].day = int.Parse(s[3]);
            }
            Array.Sort(p , 0 , n , new MyComparer());
            for (int i = 0 ; i < n ; i++)
                Console.WriteLine(p[i].name);
            //Console.ReadLine();
        }
    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值