1037. Magic Coupon (25)

The magic shop in Mars is offering some magic coupons. Each coupon has an integer N printed on it, meaning that when you use this coupon with a product, you may get N times the value of that product back! What is more, the shop also offers some bonus product for free. However, if you apply a coupon with a positive N to this bonus product, you will have to pay the shop N times the value of the bonus product... but hey, magically, they have some coupons with negative N's!

For example, given a set of coupons {1 2 4 -1}, and a set of product values {7 6 -2 -3} (in Mars dollars M$) where a negative value corresponds to a bonus product. You can apply coupon 3 (with N being 4) to product 1 (with value M$7) to get M$28 back; coupon 2 to product 2 to get M$12 back; and coupon 4 to product 4 to get M$3 back. On the other hand, if you apply coupon 3 to product 4, you will have to pay M$12 to the shop.

Each coupon and each product may be selected at most once. Your task is to get as much money back as possible.

Input Specification:

Each input file contains one test case. For each case, the first line contains the number of coupons NC, followed by a line with NC coupon integers. Then the next line contains the number of products NP, followed by a line with NP product values. Here 1<= NC, NP <= 105, and it is guaranteed that all the numbers will not exceed 230.

Output Specification:

For each test case, simply print in a line the maximum amount of money you can get back.

Sample Input:
4
1 2 4 -1
4
7 6 -2 -3
Sample Output:
43

将第一个数组和第二个数组各分为正数和负数两部分,全部降序排序,两个正数部分对应位置相乘(直到其中一个的结尾),两个负数部分对应位置相乘(直到其中一个的结尾),将相乘的结果累加即可。


代码:

#include <iostream>
#include <cstring>
#include <vector>
#include <cstdlib>
#include <cstdio>
#include <algorithm>
using namespace std;

int main()
{
	int nc;
	cin>>nc;
	vector<int>p_cou;
	vector<int>n_cou;
	for(int i=0;i<nc;i++)
	{
		int c;
		cin>>c;
		if(c>=0) p_cou.push_back(c);
		else n_cou.push_back(-c);
	}
	int np;
	cin>>np;
	vector<int>p_pro;
	vector<int>n_pro;
	for(int i=0;i<np;i++)
	{
		int p;
		cin>>p;
		if(p>=0) p_pro.push_back(p);
		else n_pro.push_back(-p);
	}
	sort(p_cou.begin(),p_cou.end(),greater<int>());
	sort(n_cou.begin(),n_cou.end(),greater<int>());
	sort(p_pro.begin(),p_pro.end(),greater<int>());
	sort(n_pro.begin(),n_pro.end(),greater<int>());
	int res=0;
	for(int i=0;i<p_cou.size()&&i<p_pro.size();i++)
	{
		res+=p_cou[i]*p_pro[i];
	}
	for(int i=0;i<n_cou.size()&&i<n_pro.size();i++)
	{
		res+=n_cou[i]*n_pro[i];
	}
	cout<<res;
}




评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值