UVAOJ401- Palindromes

/*  Palindromes 
A regular palindrome is a string of numbers or letters that is the same forward as backward. For example, the string "ABCDEDCBA" is a palindrome because it is the same when the string is read from left to right as when the string is read from right to left.


A mirrored string is a string for which when each of the elements of the string is changed to its reverse (if it has a reverse) and the string is read backwards the result is the same as the original string. For example, the string "3AIAE" is a mirrored string because "A" and "I" are their own reverses, and "3" and "E" are each others' reverses.


A mirrored palindrome is a string that meets the criteria of a regular palindrome and the criteria of a mirrored string. The string "ATOYOTA" is a mirrored palindrome because if the string is read backwards, the string is the same as the original and because if each of the characters is replaced by its reverse and the result is read backwards, the result is the same as the original string. Of course, "A", "T", "O", and "Y" are all their own reverses.


A list of all valid characters and their reverses is as follows.


Character	Reverse	Character	Reverse	Character	Reverse
A	A	M	M	Y	Y
B		N		Z	5
C		O	O	1	1
D		P		2	S
E	3	Q		3	E
F		R		4	
G		S	2	5	Z
H	H	T	T	6	
I	I	U	U	7	
J	L	V	V	8	8
K		W	W	9	
L	J	X	X		

Note that O (zero) and 0 (the letter) are considered the same character and therefore ONLY the letter "0" is a valid character.

Input 

Input consists of strings (one per line) each of which will consist of one to twenty valid characters. There will be no invalid characters in any of the strings. Your program should read to the end of file.
Output 

For each input string, you should print the string starting in column 1 immediately followed by exactly one of the following strings.

STRING	CRITERIA
" -- is not a palindrome."	 if the string is not a palindrome and is not a mirrored string
" -- is a regular palindrome."	 if the string is a palindrome and is not a mirrored string
" -- is a mirrored string."	 if the string is not a palindrome and is a mirrored string
" -- is a mirrored palindrome."	 if the string is a palindrome and is a mirrored string
Note that the output line is to include the -'s and spacing exactly as shown in the table above and demonstrated in the Sample Output below.

In addition, after each output line, you must print an empty line.

Sample Input 

NOTAPALINDROME 
ISAPALINILAPASI 
2A3MEAS 
ATOYOTA
Sample Output 

NOTAPALINDROME -- is not a palindrome.
 
ISAPALINILAPASI -- is a regular palindrome.
 
2A3MEAS -- is a mirrored string.
 
ATOYOTA -- is a mirrored palindrome.


Miguel Revilla 2001-04-16*/ 




#include<stdio.h>
#include<string.h>
int main()
{
	char s[25],pr[43]={"AEHIJLMOSTUVWXYZ12358A3HILJMO2TUVWXY51SEZ8"};
	while(scanf("%s",s)!=EOF){
	
	char*p,*o=pr;
	int ok1=1,ok2=1;
	
	int m=strlen(s);
//	printf("%d",m);
	for(int i=0;i<m/2+1;i++){
	//	printf("i=%d,s[i]=%d,s[m-i]=%d",i,s[i],s[m-i]);
		if(s[i]!=s[m-i-1]){
			ok1=0;break;
		}
	}
	for(int i=0;i<m/2+1;i++){
		if(strchr(pr,s[i])!=NULL)
		{
			p=strchr(pr,s[i]);
			
			if(p>o+20&&s[m-i-1]!=*(p-21)){
				ok2=0;
				break;
			}
			if(p<o+21&&s[m-i-1]!=*(p+21)){
				ok2=0;
				break;
			}
			
		}
		else ok2=0;
		
	}
	if(ok1&&ok2)
	printf("%s -- is a mirrored palindrome.\n\n",s);
	if(ok1&&!ok2)
	printf("%s -- is a regular palindrome.\n\n",s);
	if(!ok1&&ok2)
	printf("%s -- is a mirrored string.\n\n",s);
	if(!ok1&&!ok2)
	printf("%s -- is not a palindrome.\n\n",s);
	//printf("%d,%d \n",ok1,ok2);
	memset(s,0,sizeof(s));
	}
	return 0;
}
//1A了,判断回文不难,判断镜像需要一点技巧 。而且发现strchr函数只能搜索字符串,不能搜二维字符数组(凭我现在的知识) ,所以我定义的一开始的二维改成了一维。
//strchr返回地址加上指针很容易解决这个问题,所以要积累这些库函数知识。 
#include<stdio.h>
#include<string.h>
#include<ctype.h>

	const char* rev="A   3  HIL JM O   2TUVWXY51SE Z  8 ";                         //lrj用了一个小技巧 ,他没有像我那样,想着如何把对应的镜像字符存起来。他只存了一边,与ABCD...XYZ123..9对应了起来,没有镜像的用空格代替。 
	const char*msg[]={"not a palindrome","a regular palindrome","a mirrored string","a mirrored palindrome"}; //指针的运用的确有点方便 ,常量数组的运用体现了良好的代码风格。
	char r(char ch){
		if(isalpha(ch)) return rev[ch-'A'];                    //isalpha,idigit,isprint这些函数要学会用。 
		return rev[ch-'0'+25];
	}
	int main()
	{
		char s[30];
		while(scanf("%s",s)==1){
			int len=strlen(s);
			int p=1,m=1;
			for(int i=0;i<(len+1)/2;i++)
			{
				if(s[i]!=s[len-1-i]) p=0;
				if(r(s[i])!=s[len-1-i]) m=0;
			}
			printf("%s -- is %s.\n\n",s,msg[m*2+p]);                //这个技巧真不错,不像我那样分四行输出,最好在笔记本上推广一下。 
		}
		return 0;
	}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值