POJ P1988 Cube Stacking 并查集

Cube Stacking
Time Limit: 2000MS Memory Limit: 30000K
Total Submissions: 17018 Accepted: 5862
Case Time Limit: 1000MS

Description

Farmer John and Betsy are playing a game with N (1 <= N <= 30,000)identical cubes labeled 1 through N. They start with N stacks, each containing a single cube. Farmer John asks Betsy to perform P (1<= P <= 100,000) operation. There are two types of operations: 
moves and counts. 
* In a move operation, Farmer John asks Bessie to move the stack containing cube X on top of the stack containing cube Y. 
* In a count operation, Farmer John asks Bessie to count the number of cubes on the stack with cube X that are under the cube X and report that value. 

Write a program that can verify the results of the game. 

Input

* Line 1: A single integer, P 

* Lines 2..P+1: Each of these lines describes a legal operation. Line 2 describes the first operation, etc. Each line begins with a 'M' for a move operation or a 'C' for a count operation. For move operations, the line also contains two integers: X and Y.For count operations, the line also contains a single integer: X. 

Note that the value for N does not appear in the input file. No move operation will request a move a stack onto itself. 

Output

Print the output from each of the count operations in the same order as the input file. 

Sample Input

6
M 1 6
C 1
M 2 4
M 2 6
C 3
C 4

Sample Output

1
0
2

Source



其实这道题和银河英雄传说非常像。。。

附我百度来的题目翻译:

题目大意:
一开始有N个标号为1到N的立方体,它们各成一堆,给出两种操作:
1.M X Y :将X所在的堆叠在Y所在的堆上面,保证X和Y不在同一堆。
2.C X :计算在X所在的堆中在X下方的有多少立方块,并输出。
输入:
第一行输入P,表示下面有多少个操作
第2到p+1行,每行输入一个操作,或M X Y或C X
输出:
当有C X操作时输出


快2点了。。poj还有那么多人在刷题,,,

#include <iostream>
using namespace std;

int set[30010],count[30010],before[30010];
int i,n,x,y,fx,fy;
string s;

int FindSet(int x);
void Union(int x,int y);
int main()
{
	ios::sync_with_stdio(false);
	for (i=1;i<30010;++i){
		set[i]=i;
		count[i]=1;
		before[i]=0;
	}
	cin>>n;
	while (n--){
		cin>>s;
		if (s == "M"){
			cin>>x>>y;
			Union(x,y);
		}else{
			cin>>x;
			FindSet(x);
			cout<<before[x]<<endl;
		}
	}
	return 0;
}

int FindSet(int x){
	if (set[x] != x){
		int temp=set[x];
		set[x]=FindSet(set[x]);
		count[x]=count[temp];
		before[x]+=before[temp];
	}
	return set[x];
}

void Union(int x,int y){
	int fx=FindSet(x);
	int fy=FindSet(y);
	set[fx]=fy;
	before[fx]=count[fy];
	count[fy]+=count[fx];
	return;
}

kdwycz的网站:  http://kdwycz.com/

kdwyz的刷题空间:http://blog.csdn.net/kdwycz



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值