HDU-6324 Problem F. Grab The Tree(染色)

Problem F. Grab The Tree

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 524288/524288 K (Java/Others)
Total Submission(s): 178    Accepted Submission(s): 123


 

Problem Description

Little Q and Little T are playing a game on a tree. There are n vertices on the tree, labeled by 1,2,...,n, connected by n−1 bidirectional edges. The i-th vertex has the value of wi.
In this game, Little Q needs to grab some vertices on the tree. He can select any number of vertices to grab, but he is not allowed to grab both vertices that are adjacent on the tree. That is, if there is an edge between x and y, he can't grab both x and y. After Q's move, Little T will grab all of the rest vertices. So when the game finishes, every vertex will be occupied by either Q or T.
The final score of each player is the bitwise XOR sum of his choosen vertices' value. The one who has the higher score will win the game. It is also possible for the game to end in a draw. Assume they all will play optimally, please write a program to predict the result.

 

 

Input

The first line of the input contains an integer T(1≤T≤20), denoting the number of test cases.
In each test case, there is one integer n(1≤n≤100000) in the first line, denoting the number of vertices.
In the next line, there are n integers w1,w2,...,wn(1≤wi≤109), denoting the value of each vertex.
For the next n−1 lines, each line contains two integers u and v, denoting a bidirectional edge between vertex u and v.

 

 

Output

For each test case, print a single line containing a word, denoting the result. If Q wins, please print Q. If T wins, please print T. And if the game ends in a draw, please print D.

 

 

Sample Input

 

1

3

2 2 2

1 2

1 3

 

 

Sample Output

 

Q

 

 

Source

2018 Multi-University Training Contest 3

#include<bits/stdc++.h>
using namespace std;
#define LL long long
#define clr(a) memset(a,0,sizeof(a))

const int MAXN = 1e5+10;

int n,t;
int color[MAXN],w[MAXN];
struct node{
    int u,v;
}p[MAXN];
bool cmp(node a,node b){
    if(a.u==b.u)    return a.v<b.v;
    else return a.u<b.u;
}
int main(){
    scanf("%d",&t);
    while(t--){
        clr(w);clr(p);
        scanf("%d",&n);
        for(int i=1;i<=n;i++){
            scanf("%d",&w[i]);
        }
        for(int i=0;i<n-1;i++){
            scanf("%d%d",&p[i].u,&p[i].v);
        }
        sort(p,p+n-1,cmp);
        for(int i=0;i<n-1;i++){
            if(color[p[i].u]==0&&color[p[i].v]==0){
                color[p[i].u] = -1;
                color[p[i].v] = 1;
            }
            else{
                if(color[p[i].u]!=0){
                    color[p[i].v] = -color[p[i].u];
                }
            }
        }
        int l = 0;int r = 0;
        for(int i=0;i<n;i++){
            if(color[i]==-1){
                l = l^w[i+1];
            }
            else{
                r = r^w[i+1];
            }
        }
        l = l^0;
        r = r^0;
        if(l!=r){
            cout<<"Q"<<endl;
        }
        else{
            cout<<"D"<<endl;
        }
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值