每周一题1_杭电ACM_Identity Card

7 篇文章 0 订阅

Identity Card

题目来源:杭电ACM 1.2.8

原题描述

Problem Description
Do you own an ID card?You must have a identity card number in your family’s Household Register. From the ID card you can get specific personal information of everyone. The number has 18 bits,the first 17 bits contain special specially meanings:the first 6 bits represent the region you come from,then comes the next 8 bits which stand for your birthday.What do other 4 bits represent?You can Baidu or Google it. Here is the codes which represent the region you are in. 在这里插入图片描述
However,in your card,maybe only 33 appears,0000 is replaced by other
numbers. Here is Samuel’s ID number 331004198910120036 can you tell
where he is from?The first 2 numbers tell that he is from Zhengjiang
Province,number 19891012 is his birthday date (yy/mm/dd).
.
Input
Input will contain 2 parts: A number n in the first line,n here
means there is n test cases. For each of the test cases,there is a
string of the ID card number.
.
Output
Based on the table output where he is from and when is his
birthday. The format you can refer to the Sample Output.
.
Sample Input
1
330000198910120036
.
Sample Output
He/She is from Zhejiang,and his/her birthday is on 10,12,1989 based on the table.
.
Author
Samuel
.
Source
灰色橙子 专场
.
Recommend
zty

测试代码

/*
作者:童话
环境:Win 10 & Visual Studio 2019
时间:2021-3-12
*/
#define _CRT_SECURE_NO_WARNINGS
#include <stdio.h>

int main(void)
{
	int n;					//测试样例变量
	char id[20];			//身份证号码
	int i;
	char relation[8][10] = {{"Beijing"},
							{"Liaoning"},
							{"Shanghai"},
							{"Zhejiang"},
							{"Tibet" },
							{"Taiwan"},
							{"Hong Kong"},
							{"Macao"} };
	int label[8] = { 11,21,31,33,54,71,81,82 };

	(void)scanf("%d", &n);

	while (n--)
	{
		(void)scanf("%s", id);

		int diqu = 0;
		int year = 0;
		
		//求出地区对应的代号
		for (i = 0; i < 2; i++)
			diqu = diqu * 10 + id[i] - '0';
			
		//求出出生年份
		for (i = 6; i < 10; i ++ )
			year = year * 10 + id[i] - '0';
			
		//求出地区代号对应的省份名称
		for (i = 0; i < 8; i++)
			if (diqu == label[i])
				break;
				
		printf("He/She is from %s,and his/her birthday is on %c%c,%c%c,%d based on the table.\n", relation[i],id[10], id[11], id[12], id[13],year);
	}
	
	return 0;
}

小结一下

这题的思路就是用字符数组的方式去处理身份证号码,可以随性的跳着处理字符(求地区和年份时),输出也可以直接输出对应位置的数字。
·
·
·

附:

另一种系统没通过但是输出结果目测没有问题的代码,望指正

#define _CRT_SECURE_NO_WARNINGS
#include <stdio.h>

int main(void)
{
	int n;					//测试样例变量
	int region;				//地区变量
	int year;
	int month;
	int day;
	int i;
	char relation[8][10] = { {"Beijing"},
							{"Liaoning"},
							{"Shanghai"},
							{"Zhejiang"},
							{"Tibet" },
							{"Taiwan"},
							{"Hong Kong"},
							{"Macao"} };
	int label[8] = { 11,21,31,33,54,71,81,82 };

	(void)scanf("%d", &n);
	while (n--)
	{
		(void)scanf("%2d", &region);
		(void)scanf("%4d", &i);
		(void)scanf("%4d", &year);
		(void)scanf("%2d", &month);
		(void)scanf("%2d", &day);
		(void)scanf("%4d", &i);
		
		for (i = 0; i < 8; i++)
			if (region == label[i])
				break;
		printf("He/She is from %s,and his/her birthday is on %d,%d,%d based on the table.\n", relation[i], month, day, year);
	}

	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

童话与云

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值