HDU2476:String painter

There are two strings A and B with equal length. Both strings are made up of lower case letters. Now you have a powerful string painter. With the help of the painter, you can change a segment of characters of a string to any other character you want. That is, after using the painter, the segment is made up of only one kind of character. Now your task is to change A to B using string painter. What’s the minimum number of operations?

Input
Input contains multiple cases. Each case consists of two lines:
The first line contains string A.
The second line contains string B.
The length of both strings will not be greater than 100.

Output
A single line contains one integer representing the answer.

Sample Input
zzzzzfzzzzz
abcdefedcba
abababababab
cdcdcdcdcdcd

Sample Output
6
7

思路:
这题是一题区间DP题,先求出s2的DP再用其与s1比较,得出最后的解

代码

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <string>
using namespace std;
const int N=2005;
int dp[N][N];
int ans[N];
char s1[N],s2[N];
int main()
{
    while(~scanf("%s%s",s1,s2))
    {
       int sl=strlen(s1);
       memset(dp,0,sizeof(dp));
       for(int i=0;i<sl;i++)
       {
           for(int j=i;j>=0;j--)
           {
               dp[j][i]=dp[j+1][i]+1;
               for(int k=j+1;k<=i;k++)
               {
                   if(s2[k]==s2[j])
                   {
                       dp[j][i]=min(dp[j][i],dp[j+1][k]+dp[k+1][i]);
                   }
               }
           }
       }
       for(int i=0;i<sl;i++) ans[i]=dp[0][i];
       for(int i=0;i<sl;i++)
       {
           if(s1[i]==s2[i]) ans[i]=ans[i-1];
           else
           {
               for(int j=0;j<i;j++)
               {
                   ans[i]=min(ans[i],ans[j]+dp[j+1][i]);
               }
           }
       }
       printf("%d\n",ans[sl-1]);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值