what day is that day 打表找最小周期

 It's Saturday today, what day is it after 11 + 22 + 33 + ... + NN days?

Input

There are multiple test cases. The first line of input contains an integer T indicating the number of test cases. For each test case:

There is only one line containing one integer N (1 <= N <= 1000000000).

Output

For each test case, output one string indicating the day of week.

Sample Input

2
1
2

Sample Output

Sunday
Thursday

Hint

A week consists of Sunday, Monday, Tuesday, Wednesday, Thursday, Friday and Saturday.

AC代码

#include<iostream>
#include<cstdio>
using namespace std;
int s[295];
char st[10][12]={"Saturday","Sunday","Monday","Tuesday","Wednesday","Thursday","Friday"};//满足n为1时输出sunday
int work(int n)//work中计算的是n的n次方 
{
    int sm=1;
    for(int i=1;i<=n;i++)
    {
        sm=sm*n;
        sm=sm%7;
    }
    return sm;
}
void init()
{
    s[0]=0;
    for(int i=1;i<295;i++)
    {
        s[i]=s[i-1]+work(i);//s[i]中计算的是1^1+2^2+......  
        s[i]=s[i]%7;//每次对7取模; 
    }
}
int main()
{
    init();
    int t,n;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        n=n%294;//294为周期 
        printf("%s\n",st[s[n]]);
    }
    return 0;
}

其中找到周期为294时,是打表找到的,代码如下

#include<iostream>
#include<cstdio>
using namespace std;
int s[295];
char st[10][12]={"7","1","2","3","4","5","6"};
int work(int n)//work中计算的是n的n次方 
{
    int sm=1;
    for(int i=1;i<=n;i++)
    {
        sm=sm*n;
        sm=sm%7;
    }
    return sm;
}
void init()
{
    s[0]=0;
    for(int i=1;i<600;i++)
    {
        s[i]=s[i-1]+work(i);//s[i]中计算的是1^1+2^2+......  
        s[i]=s[i]%7;//每次对7取模; 
    }
}
int main()
{
    init();
    int t,n;
    for(int i=1;i<600;i++)
	printf("%s ",st[s[i]]);
    return 0;
}

在这里插入图片描述

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

henulmh

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值