map- Let the Balloon Rise

map- Let the Balloon Rise

Contest time again! How excited it is to see balloons floating around. But to tell you a secret, the judges’ favorite time is guessing the most popular problem. When the contest is over, they will count the balloons of each color and find the result.

This year, they decide to leave this lovely job to you.

Input

Input contains multiple test cases. Each test case starts with a number N (0 < N <= 1000) – the total number of balloons distributed. The next N lines contain one color each. The color of a balloon is a string of up to 15 lower-case letters.

A test case with N = 0 terminates the input and this test case is not to be processed.

Output

For each case, print the color of balloon for the most popular problem on a single line. It is guaranteed that there is a unique solution for each test case.

Sample Input

5
green
red
blue
red
red
3
pink
orange
pink
0

Sample Output

red
pink
#include<string>
#include<cstdio>
#include<iostream>
#include<map>
using namespace std;

map<string,int> m;
int main(){
	int n;
	while(cin>>n&&n!=0)
	{
		int num=0;
		for(int i=0;i<n;i++){
			string a;
			cin>>a;
			m[a]++;
		} 
		string b;
		for(map<string,int>::iterator ite=m.begin();ite!=m.end();ite++)
		{
			if(num<ite->second){
				num=ite->second;
				b=ite->first;
			}
		}
		cout<<b<<endl;
		m.clear();
	}
	return 0;
}

另一种

#include<iostream>
#include<cstdio>
#include<string>
#include<map>
using namespace std;
map<string,int> m;

string a;
int main()
{
	int n;
	while(1)
	{/*做无限循环直到为零跳出循环*/ 
		cin>>n;
		if(n==0)
		{
			break;
		}	
		m.clear();/*清空map里的键值*/
		for(int i=0;i<n;i++)
		{/*将字符串依次存入a*/
			cin>>a;
				if(0==m.count(a))
			{
				m.insert(make_pair(a,1));
			} 
			else 
			{
				m[a]++;
			}/*如果map里没有相映的字符串就设定一个键并给值1,有就加一*/
		}
		map<string,int>::iterator ite;	/*迭代器用来查询*/
		pair<string,int> pa=make_pair("\0",-1);
		/*定义用来存入当前最大的数据*/
		for(ite=m.begin();ite!=m.end();ite++)
		{/*依次查询map的值*/
			ite->second;
			if(ite->second>pa.second)
			{/*用来存入当前最大的数据*/
				pa=*ite;
			}
		}/*pa.first存的是字符串,pa.second存的是字符串的个数*/
		cout<<pa.first<<endl;
	}
	return 0;
}
  • 2
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值