面向对象程序设计上机练习十一(运算符重载)

面向对象程序设计上机练习十一(运算符重载)

Time Limit: 1000MS  Memory Limit: 65536KB
Problem Description
有两个矩阵a和b,均为2行3列,求两个矩阵之和。重载运算符“+”,使之能用于矩阵相加。如:c=a+b。
Input
第1、2行是矩阵a的值,数据以空格分开。
第3、4行是矩阵b的值,数据以空格分开。
Output
2个矩阵a、b之和,以行列形式显示。
Example Input
2 3 4
3 5 3
4 3 1
5 4 3
Example Output
6 6 5
8 9 6
 
 
#include <iostream>
using namespace std;
class Complex
{
    int a[2][3];
    public:
        void Input()
        {
            for(int i=0;i<2;i++)
                for(int j=0;j<3;j++)
                    cin>>a[i][j];
        }
        Complex() {}
        Complex operator + (Complex &b)
        {
            Complex c;
            for(int i=0;i<2;i++)
                for(int j=0;j<3;j++)
                {
                    c.a[i][j]=this->a[i][j]+b.a[i][j];
                }
            return c;
        }
        void Show()
        {
            int i,j;
            for( i=0;i<2;i++)
            {
                for(j=0;j<2;j++)
                {
                    cout<<a[i][j]<<" ";
                }
                cout<<a[i][j]<<endl;
            }


        }


};
int main()
{
    Complex a,b,c;
    a.Input();
    b.Input();
    c=a+b;
    c.Show();
    return 0;
}
方法二:
#include <iostream>
using namespace std;
class Complex
{
    double real,imag;
public:
    operator double()  //类型转换函数
    {
        return real;
    }
    Complex (double a=0,double b=0)
    {
        real=a;
        imag=b;
    }
};
int main()
{
    double a,b,c;
    cin>>a>>b>>c;
    Complex c1(a,b);
    double d=c1+c;
    cout<<d<<endl;
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值