HDU1026:Ignatius and the Princess I(BFS)

Problem Description
The Princess has been abducted by the BEelzebub feng5166, our hero Ignatius has to rescue our pretty Princess. Now he gets into feng5166's castle. The castle is a large labyrinth. To make the problem simply, we assume the labyrinth is a N*M two-dimensional array which left-top corner is (0,0) and right-bottom corner is (N-1,M-1). Ignatius enters at (0,0), and the door to feng5166's room is at (N-1,M-1), that is our target. There are some monsters in the castle, if Ignatius meet them, he has to kill them. Here is some rules:

1.Ignatius can only move in four directions(up, down, left, right), one step per second. A step is defined as follow: if current position is (x,y), after a step, Ignatius can only stand on (x-1,y), (x+1,y), (x,y-1) or (x,y+1).
2.The array is marked with some characters and numbers. We define them like this:
. : The place where Ignatius can walk on.
X : The place is a trap, Ignatius should not walk on it.
n : Here is a monster with n HP(1<=n<=9), if Ignatius walk on it, it takes him n seconds to kill the monster.

Your task is to give out the path which costs minimum seconds for Ignatius to reach target position. You may assume that the start position and the target position will never be a trap, and there will never be a monster at the start position.
 

Input
The input contains several test cases. Each test case starts with a line contains two numbers N and M(2<=N<=100,2<=M<=100) which indicate the size of the labyrinth. Then a N*M two-dimensional array follows, which describe the whole labyrinth. The input is terminated by the end of file. More details in the Sample Input.
 

Output
For each test case, you should output "God please help our poor hero." if Ignatius can't reach the target position, or you should output "It takes n seconds to reach the target position, let me show you the way."(n is the minimum seconds), and tell our hero the whole path. Output a line contains "FINISH" after each test case. If there are more than one path, any one is OK in this problem. More details in the Sample Output.
 

Sample Input
  
  
5 6 .XX.1. ..X.2. 2...X. ...XX. XXXXX. 5 6 .XX.1. ..X.2. 2...X. ...XX. XXXXX1 5 6 .XX... ..XX1. 2...X. ...XX. XXXXX.
 

Sample Output
  
  
It takes 13 seconds to reach the target position, let me show you the way. 1s:(0,0)->(1,0) 2s:(1,0)->(1,1) 3s:(1,1)->(2,1) 4s:(2,1)->(2,2) 5s:(2,2)->(2,3) 6s:(2,3)->(1,3) 7s:(1,3)->(1,4) 8s:FIGHT AT (1,4) 9s:FIGHT AT (1,4) 10s:(1,4)->(1,5) 11s:(1,5)->(2,5) 12s:(2,5)->(3,5) 13s:(3,5)->(4,5) FINISH It takes 14 seconds to reach the target position, let me show you the way. 1s:(0,0)->(1,0) 2s:(1,0)->(1,1) 3s:(1,1)->(2,1) 4s:(2,1)->(2,2) 5s:(2,2)->(2,3) 6s:(2,3)->(1,3) 7s:(1,3)->(1,4) 8s:FIGHT AT (1,4) 9s:FIGHT AT (1,4) 10s:(1,4)->(1,5) 11s:(1,5)->(2,5) 12s:(2,5)->(3,5) 13s:(3,5)->(4,5) 14s:FIGHT AT (4,5) FINISH God please help our poor hero. FINISH
 


 

简单BFS,只要注意保存路径即可

 


#include <stdio.h>
#include <string.h>
#include <queue>
using namespace std;

struct node
{
    int x,y,step;
    friend bool operator<(node n1,node n2)
    {
        return n2.step<n1.step;
    }
};

int map[105][105];
int flag[105][105];
int cnt[105][105];//记录怪的血量
int to[4][2] = {1,0,-1,0,0,1,0,-1};
int n,m,tim;

int check(int x,int y)
{
    if(x<0 || y<0 || x>=n || y>=m)
        return 1;
    if(map[x][y] == -1)
        return 1;
    return 0;
}

int bfs()
{
    int i;
    priority_queue<node> Q;
    node a,next;
    a.x = 0;
    a.y = 0;
    a.step = 0;
    map[0][0] = -1;
    Q.push(a);
    while(!Q.empty())
    {
        a = Q.top();
        Q.pop();
        if(a.x == n-1  && a.y == m-1)
            return a.step;
        for(i = 0; i<4; i++)
        {
            next = a;
            next.x+=to[i][0];
            next.y+=to[i][1];
            if(check(next.x,next.y))
                continue;
            next.step =a.step+map[next.x][next.y]+1;//记录时间
            map[next.x][next.y] = -1;//标记为走过
            flag[next.x][next.y] = i+1;//记录朝向
            Q.push(next);
        }
    }
    return 0;
}

void print(int x,int y)
{
    int n_x,n_y;
    if(!flag[x][y])
        return;
    n_x = x - to[flag[x][y]-1][0];
    n_y = y - to[flag[x][y]-1][1];
    print(n_x,n_y);
    printf("%ds:(%d,%d)->(%d,%d)\n",tim++,n_x,n_y,x,y);
    while(cnt[x][y]--)
    {
        printf("%ds:FIGHT AT (%d,%d)\n",tim++,x,y);
    }
}

int main()
{
    int i,j;
    while(~scanf("%d%d",&n,&m))
    {
        memset(map,0,sizeof(map));
        memset(flag,0,sizeof(flag));
        memset(cnt,0,sizeof(cnt));
        char s[105];
        for(i = 0; i<n; i++)
        {
            scanf("%s",s);
            for(j = 0; s[j]; j++)
            {
                if(s[j] == '.')
                    map[i][j] = 0;
                else if(s[j] == 'X')
                    map[i][j] = -1;
                else
                    map[i][j] = cnt[i][j] = s[j]-'0';
            }
        }
        int ans = 0;
        ans = bfs();
        if(ans)
        {
            printf("It takes %d seconds to reach the target position, let me show you the way.\n",ans);
            tim = 1;
            print(n-1,m-1);
        }
        else
            printf("God please help our poor hero.\n");
        printf("FINISH\n");
    }

    return 0;
}





 

  • 0
    点赞
  • 3
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值