I - Largest Rectangle in a Histogram HDU - 1506

A histogram is a polygon composed of a sequence of rectangles aligned at a common base line. The rectangles have equal widths but may have different heights. For example, the figure on the left shows the histogram that consists of rectangles with the heights 2, 1, 4, 5, 1, 3, 3, measured in units where 1 is the width of the rectangles: 
 
Usually, histograms are used to represent discrete distributions, e.g., the frequencies of characters in texts. Note that the order of the rectangles, i.e., their heights, is important. Calculate the area of the largest rectangle in a histogram that is aligned at the common base line, too. The figure on the right shows the largest aligned rectangle for the depicted histogram.

Input

The input contains several test cases. Each test case describes a histogram and starts with an integer n, denoting the number of rectangles it is composed of. Y

ou may assume that 1 <= n <= 100000. Then follow n integers h1, ..., hn, where 0 <= hi <= 1000000000. These numbers denote the heights of the rectangles of the histogram in left-to-right order. The width of each rectangle is 1. A zero follows the input for the last test case.

Output

For each test case output on a single line the area of the largest rectangle in the specified histogram. Remember that this rectangle must be aligned at the common base line.

Sample Input

7 2 1 4 5 1 3 3
4 1000 1000 1000 1000
0

Sample Output

8
4000

题意:求直方图中最大的矩形。

思路:我们对于每一个点都要求出它的左右极限然后进行计算面积操作,那么我通过将求出这个点的左极限的方式,同理可以求出右极限。

        对于左极限L的求法,我们从第1个数一直去求到n(两个端点),对于1这样的没有左极限的,那么它的左极限就是它本身,加下来看2,我们拿它和1比较,决定了它的左极限L是它本身还是1......接下来对于第i个点,我们求它的左极限L,先拿它和它左边的那个数比较,如果比它大或者等于它,那么我们首先就可以把i的左极限推到了i-1的左极限L[i-1]这个点了,那么我们此时是否要结束判断?——这取决于L[i-1]-1这个点了,为什么呢?因为既然i这个点小于等于i-1点的高度,那么i-1这个点的左极限能被i继承,但是若是i-1这个点比i高,那么这就是个“充分不必要”条件了,我们此时并不能确定L[i-1]-1这个点的高度是否比i高,所以一一判断,这样,我们就可以推出了一则有用的公式:

 

            while(l[i]>0&&a[l[i]-1]>=a[i])

            {

                l[i]=l[l[i]-1];

            }

 

        同理,我们可以用类似的方法求出每个点的右极限

#include<stdio.h>
#include<string.h>
long long a[100010],l[100010],r[100010];
int main()
{
    long long i,j,n,max;
    while(~scanf("%lld",&n)&&n!=0)
    {
        for(i=1;i<=n;i++)
        {
            scanf("%lld",&a[i]);
        }
        l[1]=1,r[n]=n;
        for(i=2;i<=n;i++)
        {
            j=i;
            while(a[i]<=a[j-1] && j>0)
                j=l[j-1];
            l[i]=j;
        }
        for(i=n-1;i>=1;i--)
        {
            j=i;
            while(a[i]<=a[j+1] && j<n)
                j=r[j+1];
            r[i]=j;
        }
        max=-9999;
        for(i=1;i<=n;i++)
        {
            if((r[i]-l[i]+1)*a[i]>max)
                max=(r[i]-l[i]+1)*a[i];
        }
        printf("%lld\n",max);
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值