PAT-A1102. 二叉树-翻转 层序、中序输出

题目链接:https://www.patest.cn/contests/pat-a-practise/1102

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (<=10) which is the total number of nodes in the tree – and hence the nodes are numbered from 0 to N-1. Then N lines follow, each corresponds to a node from 0 to N-1, and gives the indices of the left and right children of the node. If the child does not exist, a “-” will be put at the position. Any pair of children are separated by a space.

Output Specification:

For each test case, print in the first line the level-order, and then in the second line the in-order traversal sequences of the inverted tree. There must be exactly one space between any adjacent numbers, and no extra space at the end of the line.

Sample Input:

8
1 -
- -
0 -
2 7
- -
- -
5 -
4 6

Sample Output:

3 7 2 6 4 0 5 1
6 5 7 4 3 2 0 1

注意根结点序号的获取方式,根结点不是任何结点的子结点,所以遍历输入数据,没出现过的序号就是根结点。

#include <iostream>
#include <queue>
#include <cstring>
using namespace std;

struct BTree{
    char lchild, rchild;
};

BTree T[12];
bool bt[12];
int nindex = 0;
int num = 0;

void InOrder(char n)
{
    if(n == '-')
        return;
    else{
        InOrder(T[n-'0'].lchild);
        cout << n;
        nindex++;
        if(nindex < num)
            cout << ' ';
        else
            cout << endl;
        InOrder(T[n-'0'].rchild);
    }

}

void LevelOrder(char n, int num)
{
    queue<char> qt;
    qt.push(n);
    while (!qt.empty()) {
        char c = qt.front();
        qt.pop();
        cout << c;
        num--;
        if(num>0)
            cout << " ";
        else
            cout << endl;
        if(T[c-'0'].lchild!='-')
            qt.push(T[c-'0'].lchild);
        if(T[c-'0'].rchild!='-')
            qt.push(T[c-'0'].rchild);
    }
}

int getRoot()
{
    for(int i = 0; i < num; ++i){
        if(!bt[i]){
            return i;
        }
    }
    return 0;
}

int main()
{
    cin >> num;
    memset(bt, 0, sizeof(bt));
    for(int i = 0; i < num; ++i){
        cin >> T[i].rchild >> T[i].lchild;
        if(T[i].rchild!='-')
            bt[T[i].rchild-'0']=true;
        if(T[i].lchild!='-')
            bt[T[i].lchild-'0']=true;
    }
    nindex = 0;
    int root = getRoot();
    LevelOrder('0'+root, num);
    InOrder('0'+root);

    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值