PAT-A1115. 二叉树-构建BST,分层统计结点

题目链接:https://www.patest.cn/contests/pat-a-practise/1115
A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

The left subtree of a node contains only nodes with keys less than or equal to the node’s key.
The right subtree of a node contains only nodes with keys greater than the node’s key.
Both the left and right subtrees must also be binary search trees.
Insert a sequence of numbers into an initially empty binary search tree. Then you are supposed to count the total number of nodes in the lowest 2 levels of the resulting tree.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (<=1000) which is the size of the input sequence. Then given in the next line are the N integers in [-1000 1000] which are supposed to be inserted into an initially empty binary search tree.

Output Specification:

For each case, print in one line the numbers of nodes in the lowest 2 levels of the resulting tree in the format:

n1 + n2 = n

where n1 is the number of nodes in the lowest level, n2 is that of the level above, and n is the sum.

Sample Input:

9
25 30 42 16 20 20 35 -5 28

Sample Output:
2 + 4 = 6

BST中插入一个结点(不考虑平衡),比较 结点值的大小,较小就插入左子树,较大就插入右子树。
层序遍历时判断哪些结点在同一层的一般思路是:标记该层最左边的结点,当要弹出该标记结点时就意味着上一层已经遍历结束,开始新的一层。

#include <iostream>
#include <queue>
#include <vector>
using namespace std;

int data[1010];

struct BTree {
    int data;
    BTree *lchild, *rchild;
};
BTree *T;


void InsertValue(BTree *father, BTree *node)
{

    if(node->data <= father->data){
        if(father->lchild == NULL)
            father->lchild = node;
        else
            InsertValue(father->lchild, node);
    }
    else{
        if(father->rchild == NULL)
            father->rchild = node;
        else
            InsertValue(father->rchild, node);
    }

}

void LevelOrder(BTree *root)
{
    queue<BTree*> qt;
    qt.push(root);
    BTree *left = NULL;
    bool findleft = false;
    vector<vector<int>> values;
    vector<int> vetemp;

    while (!qt.empty()) {
        BTree *temp = qt.front();
        qt.pop();
        if(temp == left){
            findleft = false;
            left = NULL;
            values.push_back(vetemp);
            vetemp.clear();
        }
        vetemp.push_back(temp->data);
        if(temp->lchild != NULL){
            qt.push(temp->lchild);
            if(!findleft){
                findleft = true;
                left = temp->lchild;
            }
        }
        if(temp->rchild != NULL){
            qt.push(temp->rchild);
            if(!findleft){
                findleft = true;
                left = temp->rchild;
            }
        }
    }
    values.push_back(vetemp);
    long a,b;
    a = values[values.size()-1].size();
    b = values[values.size()-2].size();
    cout << a << " + " << b << " = " << a+b <<endl;
}

int main()
{
    int num;
    cin >> num;

    T = new BTree();
    cin >> T->data;
    T->lchild = NULL;
    T->rchild = NULL;

    for(int i = 1; i < num; ++i){
        cin >> data[i];
        BTree *temp = new BTree();
        temp->data = data[i];
        temp->lchild = NULL;
        temp->rchild = NULL;
        InsertValue(T, temp);
    }

    LevelOrder(T);

    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值