pat甲级1004 Counting Leaves (建图+dfs)

1004 Counting Leaves (30 分)

A family hierarchy is usually presented by a pedigree tree. Your job is to count those family members who have no child.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 0<N<100, the number of nodes in a tree, and M (<N), the number of non-leaf nodes. Then M lines follow, each in the format:

ID K ID[1] ID[2] ... ID[K]

where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID's of its children. For the sake of simplicity, let us fix the root ID to be 01.

The input ends with N being 0. That case must NOT be processed.

Output Specification:

For each test case, you are supposed to count those family members who have no child for every seniority level starting from the root. The numbers must be printed in a line, separated by a space, and there must be no extra space at the end of each line.

The sample case represents a tree with only 2 nodes, where 01 is the root and 02 is its only child. Hence on the root 01 level, there is 0 leaf node; and on the next level, there is 1 leaf node. Then we should output 0 1 in a line.

Sample Input:

2 1
01 1 02

Sample Output:

0 1

解题思路

题目意思大致是,n表示这个家族的总人数,m表示接下来会给m行,每行先是一个ID ,然后一个k,后面k个ID都ID的孩子。为了简单起见,题目设置了只有一个祖先01。接着建图,从家长指向孩子,因为ID都是两位数,建图的时候开100就行了。开个数组初始化为0,然后跑dfs存答案。因为输出要求输出每一辈里面没有孩子的人数,所以要记一下有几辈。

#include <iostream>
#include <cstring>
#include <vector>
using namespace std;
int ans[105];
int q;   //总辈数
vector<int> g[105];
void dfs(int x, int cnt)   //cnt表示x是第辈代
{
	if(g[x].size() == 0)   //x没孩子
		ans[cnt] ++;     //第cnt辈没孩子的++
	if(cnt > q)
		q = cnt;
	for(int i = 0; i < g[x].size(); i ++){
		dfs(g[x][i], cnt + 1);
	}
}
int main()
{
	int n, m;
	while(cin >> n >> m && n){	
		memset(ans, 0, sizeof(ans));
		for(int i = 0; i < m; i ++){
			int x, k;
			cin >> x >> k;
			for(int i = 0; i < k; i ++){
				int y;
				cin >> y;
				g[x].push_back(y);
			}
		}
		q = 0;
		dfs(1, 0);
		for(int i = 0; i < q; i ++){
			cout << ans[i] << " ";
		}
		cout << ans[q] << endl;
		for(int i = 0; i <= 100; i ++)
			g[i].clear();
	}
	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值