2199 Can you solve this equation?

Can you solve this equation?

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 12728    Accepted Submission(s): 5675


Problem Description
Now,given the equation 8*x^4 + 7*x^3 + 2*x^2 + 3*x + 6 == Y,can you find its solution between 0 and 100;
Now please try your lucky.
 

Input
The first line of the input contains an integer T(1<=T<=100) which means the number of test cases. Then T lines follow, each line has a real number Y (fabs(Y) <= 1e10);
 

Output
For each test case, you should just output one real number(accurate up to 4 decimal places),which is the solution of the equation,or “No solution!”,if there is no solution for the equation between 0 and 100.
 

Sample Input
  
  
2 100 -4
 

Sample Output
  
  
1.6152 No solution!

题意:

给出一个数 y ,在 [ 0 , 100 ] 区间内,找出一个数 x ,使得把 x 带入方程中求得的值和 y 相差的精度小于0.00.....001(四位小数以上就行),如果找不到,输出相应提示...


分析:

这个题用二分法,用循环递归缩小范围,一直逼近 y 的值,最后求得所需要的值 x ......

主要是二分思想和循环的控制....


二分思想,简单的来说,就是折半折半的进行查找和操作,比单纯的一个一个枚举省了很多时间......


#include<stdio.h>
#include<math.h>
double f(double x)
{
    return 8*x*x*x*x+7*x*x*x+2*x*x+3*x+6;//方程函数
}
int main()
{
    int t;double y,l,r,x;
    scanf("%d",&t); 
    while(t--)
    {
        scanf("%lf",&y);
        if(y<f(0)||y>f(100))//特判不可能的情况
        {
            printf("No solution!\n");
            continue;
        }
        l=0;r=100;//左右区间
        do
        {
            x=(l+r)/2.0;//找中间
            if(f(x)<y)//判断现在的值比给出的值大还是小
            {
                l=x;//中间值比较小,就舍弃左边的区间
            }
            else
            {
                r=x;//舍弃右边的区间
            }
        }while(fabs(f(x)-y)>1e-6);//判断跳出的条件
        printf("%.4lf\n",x);
    }    
    return 0;
} 




评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值