Counting Nodes in a Binary Search Tree

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

The left subtree of a node contains only nodes with keys less than or equal to the node’s key.
The right subtree of a node contains only nodes with keys greater than the node’s key.
Both the left and right subtrees must also be binary search trees.
Insert a sequence of numbers into an initially empty binary search tree. Then you are supposed to count the total number of nodes in the lowest 2 levels of the resulting tree.

Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N (≤1000) which is the size of the input sequence. Then given in the next line are the N integers in [−1000,1000] which are supposed to be inserted into an initially empty binary search tree.

Output Specification:
For each case, print in one line the numbers of nodes in the lowest 2 levels of the resulting tree in the format:

n1 + n2 = n
where n1 is the number of nodes in the lowest level, n2 is that of the level above, and n is the sum.

Sample Input:

10
25 30 42 16 20 20 35 -5 28 22

Sample Output:

3 + 4 = 7

题目大意:按照给定的序列建立一颗二叉排序树,然后输出最下面两层的结点个数。

#include<bits/stdc++.h>
using namespace std;
typedef struct Tree {
    int data;
    int level; // 结点所在的层数
    struct Tree *lchild, *rchild;
}bstnode, *bstree;
int n, a[1010];
int height = 0; //树高
int sum1 = 0, sum2 = 0;
void BST_insert(bstree &T, int k, int cnt) {
    height = max(height, cnt);
    if(T == NULL) {
        T = (bstree) malloc (sizeof(bstnode));
        T -> data = k;
        T -> level = cnt;
        T -> lchild = T -> rchild = NULL;
    }
    else if(k <= T -> data) BST_insert(T -> lchild, k, cnt + 1);
    else BST_insert(T -> rchild, k, cnt + 1);
}
void Create_BST(bstree &T) {
    T = NULL;
    scanf("%d", &n);
    for(int i = 0; i < n; i++) {
        scanf("%d", &a[i]);
        BST_insert(T, a[i], 1);
    }
}
void inorder(bstree T) {
    if(T == NULL) return;
    inorder(T -> lchild);
    //cout << T -> data << " ";
    if(T -> level == height) sum1++;
    if(T -> level == height - 1) sum2++;
    inorder(T -> rchild);
}
int main() {
    bstree tree;
    Create_BST(tree);
    inorder(tree);
    printf("%d + %d = %d", sum1, sum2, sum1 + sum2);
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值