Heaps

In computer science, a heap is a specialized tree-based data structure that satisfies the heap property: if P is a parent node of C, then the key (the value) of P is either greater than or equal to (in a max heap) or less than or equal to (in a min heap) the key of C. A common implementation of a heap is the binary heap, in which the tree is a complete binary tree. (Quoted from Wikipedia at https://en.wikipedia.org/wiki/Heap_(data_structure))

Your job is to tell if a given complete binary tree is a heap.

Input Specification:
Each input file contains one test case. For each case, the first line gives two positive integers: M (≤ 100), the number of trees to be tested; and N (1 < N ≤ 1,000), the number of keys in each tree, respectively. Then M lines follow, each contains N distinct integer keys (all in the range of int), which gives the level order traversal sequence of a complete binary tree.

Output Specification:
For each given tree, print in a line Max Heap if it is a max heap, or Min Heap for a min heap, or Not Heap if it is not a heap at all. Then in the next line print the tree’s postorder traversal sequence. All the numbers are separated by a space, and there must no extra space at the beginning or the end of the line.

Sample Input:

3 8
98 72 86 60 65 12 23 50
8 38 25 58 52 82 70 60
10 28 15 12 34 9 8 56

Sample Output:

Max Heap
50 60 65 72 12 23 86 98
Min Heap
60 58 52 38 82 70 25 8
Not Heap
56 12 34 28 9 8 15 10

题目大意:
给一颗完全二叉树的顺序存储,判断该二叉树是大根堆、小根堆还是不是堆,然后输出该二叉树的后序遍历。

解题思路:
判断小根堆只需将顺序表a[1…n]视为一颗完全二叉树,扫描所有分支节点,遇到孩子结点的关键字小于根节点的关键字时返回false,扫描完后返回true。大根堆相反。

#include<bits/stdc++.h>
using namespace std;
const int maxn = 1e3+10;
int t, n;
int a[maxn];
bool isMinHeap(int a[]) {
    if(n % 2 == 0) { //长度为偶数,有一个单分支结点
        if(a[n] < a[n/2]) return false; // 判断单分支结点
        for(int i = n / 2 - 1; i >= 1; i--) { //判断所有双分支结点
            if(a[i] > a[i * 2] || a[i] > a[i*2+1]) return false;
        }
    } else { // n为奇数时,没有单分支结点 
        for(int i = n / 2; i >= 1; i--) { //判断所有双分支结点
            if(a[i] > a[i * 2] || a[i] > a[i*2+1]) return false;
        }
    }
    return true;
}
bool isMaxHeap(int a[]) {
    if(n % 2 == 0) {
        if(a[n] > a[n/2]) return false;
        for(int i = n / 2 - 1; i >= 1; i--) {
            if(a[i] < a[i * 2] || a[i] < a[i*2+1]) return false;
        }
    } else {
        for(int i = n / 2; i >= 1; i--) {
            if(a[i] < a[i * 2] || a[i] < a[i*2+1]) return false;
        }
    }
    return true;
}
int cnt;
void postorder(int k) {
    if(k > n) return;
    postorder(k * 2);
    postorder(k * 2 + 1);
    if(cnt != n-1) {
        printf("%d ", a[k]);
        cnt++;
    }
    else printf("%d\n", a[k]);
}
int main() {
    scanf("%d%d", &t, &n);
    while (t--)
    {
        for(int i = 1; i <= n; i++) scanf("%d", &a[i]);
        cnt = 0;
        if(isMaxHeap(a)) {
            puts("Max Heap");
            postorder(1);
        } else if(isMinHeap(a)) {
            puts("Min Heap");
            postorder(1);
        } else {
            puts("Not Heap");
            postorder(1);
        }
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值