uva 112 Tree Summing

                        uva 112 Tree Summing


Background

LISP was one of the earliest high-level programming languages and, with FORTRAN, is one of the oldest languages currently being used. Lists, which are the fundamental data structures in LISP, can easily be adapted to represent other important data structures such as trees.

This problem deals with determining whether binary trees represented as LISP S-expressions possess a certain property.

The Problem

Given a binary tree of integers, you are to write a program that determines whether there exists a root-to-leaf path whose nodes sum to a specified integer. For example, in the tree shown below there are exactly four root-to-leaf paths. The sums of the paths are 27, 22, 26, and 18.

picture25

Binary trees are represented in the input file as LISP S-expressions having the following form.

empty tree 		 ::= 		 ()

tree ::= empty treetex2html_wrap_inline118 (integer treetree)

The tree diagrammed above is represented by the expression (5 (4 (11 (7 () ()) (2 () ()) ) ()) (8 (13 () ()) (4 () (1 () ()) ) ) )

Note that with this formulation all leaves of a tree are of the form (integer () () )

Since an empty tree has no root-to-leaf paths, any query as to whether a path exists whose sum is a specified integer in an empty tree must be answered negatively.

The Input

The input consists of a sequence of test cases in the form of integer/tree pairs. Each test case consists of an integer followed by one or more spaces followed by a binary tree formatted as an S-expression as described above. All binary tree S-expressions will be valid, but expressions may be spread over several lines and may contain spaces. There will be one or more test cases in an input file, and input is terminated by end-of-file.

The Output

There should be one line of output for each test case (integer/tree pair) in the input file. For each pair I,T (I represents the integer, T represents the tree) the output is the string yes if there is a root-to-leaf path in T whose sum is I and no if there is no path in T whose sum is I.

Sample Input

22 (5(4(11(7()())(2()()))()) (8(13()())(4()(1()()))))
20 (5(4(11(7()())(2()()))()) (8(13()())(4()(1()()))))
10 (3 
     (2 (4 () () )
        (8 () () ) )
     (1 (6 () () )
        (4 () () ) ) )
5 ()

Sample Output

yes
no
yes
no


题目大意:给出一颗树,每个节点有它自己的value,从根节点到每的叶子节点的路径上所有value的和为该叶子的值,判断这棵树上是否有叶子的值等于所给的数值。

解题思路:



#include<stdio.h>
#include<string.h>
#define N 10005
int SUM[N], n;
struct Node {       //树节点
	Node *left, *right;
	int value;
	Node() {
		value = 0;
		left = right = NULL;
	}
};
Node *build() {   //建树函数
	int flag = 0, flag2 = 0, flag3 = 0;
	Node *temp;
	temp = new Node;
	char ch;
	while (scanf("%c", &ch)) {
		if (ch == '(') {
			if (!flag) {
				temp -> left = build();
				flag++;
			}
			else if (flag) {
				temp -> right = build();
			}
		}
		else if (ch == '-') {
			flag2 = 1;
		}
		else if (ch >= '0' && ch <= '9') {
			temp -> value = temp -> value * 10 + ch - '0';
		}
		else if (ch == ')') {
			break;
		}
	}
	if (flag2) {
		temp -> value = - temp -> value;
	}
	if (!flag3 && !flag) {
		return NULL;
	}
	return temp;
}
void DFS (Node *temp, int s) {   //深度优先遍历,遍历树
	if (temp == NULL) {
		return ;
	}
	s += temp -> value;
	if (temp -> left == NULL && temp -> right == NULL) {
		SUM[n++] = s;
		return;
	}
	if (temp -> left != NULL) {
		DFS (temp -> left, s);
	}	
	if (temp -> right != NULL) {
		DFS (temp -> right, s);
	}
}
void delete_tree(Node * temp){      //删除数
	if (temp == NULL)  
		return ;  
	if (temp -> left != NULL)  
		delete_tree(temp -> left);  
	if (temp -> right != NULL)  
		delete_tree(temp -> right);  
	delete temp;  
}  
int main() {
	int sum;
	char ch;
	Node *head;
	while(scanf("%d", &sum) != EOF) {	
		n = 0;
		memset(SUM, 0, sizeof(SUM));
		head = new Node;
		while(scanf("%c", &ch)) {
			if (ch == '(') {
				head = build();	   
				break;
			}
		}
		DFS (head, 0);
		int flag = 0;
		for (int i = 0; i < n; i++) {
			if (SUM[i] == sum) {
				flag = 1;
				break;
			}
		}
		if (flag) {
			printf("yes\n");
		}
		else {
			printf("no\n");
		}
		delete head;
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值