HDU 1316 —How many Fibs?

Recall the definition of the Fibonacci numbers:

f 1 := 1 
f 2 := 2 
f n :=  f n-1 +  f n-2     (n>=3)
Given two numbers  a  and  b , calculate how many Fibonacci numbers are in the range [  a b ].

Input Specification

The input contains several test cases. Each test case consists of two non-negative integer numbers a and b. Input is terminated by a=b=0. Otherwise, a<=b<=10100. The numbers a and b are given with no superfluous leading zeros.

Output Specification

For each test case output on a single line the number of Fibonacci numbers fi with a<=fi<=b.

Sample Input

10 100
1234567890 9876543210
0 0

Sample Output

5
4
代码如下:
<pre name="code" class="cpp">#include<stdio.h>
#include<string.h>
char f[600][1200];
char *add(char *s1,char *s2)//大数加法
{      char s[1200];
       int len1=strlen(s1),len2=strlen(s2);
       strrev(s1);strrev(s2);
       int i=0,j=0,r=0,cnt=0,tem;
        while(i<len1||j<len2)
        {   if(i<len1&&j<len2)
                tem=s1[i]-'0'+s2[j]-'0'+cnt;
            if(i<len1&&j>=len2)
                tem=s1[i]-'0'+cnt;
            if(i>=len1&&j<len2)
                tem=s2[j]-'0'+cnt;
            s[r++]=tem%10+'0';
            cnt=tem/10;i++;j++;
        }
        if(cnt)
            s[r++]=cnt+'0';
        s[r]='\0';
        strrev(s1);strrev(s2);strrev(s);
        return s;
}
int strcmp1(char *a,char *b)//自定义字符串比较函数
{
    int len1=strlen(a);
    int len2=strlen(b);
    if(len1>len2)
        return 1;
    else if(len1<len2)
        return -1;
    else
    return strcmp(a,b);
}
int main()
{
    int i,ans;
    char a[110],b[110];
    strcpy(f[1],"1");
    strcpy(f[2],"2");
    for(i=3;i<490;i++)
        strcpy(f[i],add(f[i-1],f[i-2]));

    while(scanf("%s%s",a,b))//不可用while(scanf("%s%s",a,b)&&strcmp(a,"0")==0&&strcmp(b,"0")==0因为a可以为0
    {                       //需注意
        if(strcmp(a,"0")==0&&strcmp(b,"0")==0)
            break;
        ans=0;
        for(i=1;;i++){
            if(strcmp1(f[i],a)>=0&&strcmp1(b,f[i])>=0)
                ans++;
            if(strcmp1(b,f[i])<0)
                break;
        }
        printf("%d\n",ans);
    }
    return 0;
}


 

                
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值