1089 Insert or Merge (25分)【归并排序、插入排序】

1089 Insert or Merge (25分)

According to Wikipedia:

Insertion sort iterates, consuming one input element each repetition, and growing a sorted output list. Each iteration, insertion sort removes one element from the input data, finds the location it belongs within the sorted list, and inserts it there. It repeats until no input elements remain.

Merge sort works as follows: Divide the unsorted list into N sublists, each containing 1 element (a list of 1 element is considered sorted). Then repeatedly merge two adjacent sublists to produce new sorted sublists until there is only 1 sublist remaining.

Now given the initial sequence of integers, together with a sequence which is a result of several iterations of some sorting method, can you tell which sorting method we are using?

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤100). Then in the next line, N integers are given as the initial sequence. The last line contains the partially sorted sequence of the N numbers. It is assumed that the target sequence is always ascending. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in the first line either "Insertion Sort" or "Merge Sort" to indicate the method used to obtain the partial result. Then run this method for one more iteration and output in the second line the resuling sequence. It is guaranteed that the answer is unique for each test case. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

Sample Input 1:

10
3 1 2 8 7 5 9 4 6 0
1 2 3 7 8 5 9 4 6 0

Sample Output 1:

Insertion Sort
1 2 3 5 7 8 9 4 6 0

Sample Input 2:

10
3 1 2 8 7 5 9 4 0 6
1 3 2 8 5 7 4 9 0 6

Sample Output 2:

Merge Sort
1 2 3 8 4 5 7 9 0 6

解题思路:

本题需要直接模拟插入排序和归并排序的每一个步骤,其中归并排序使用非递归形式会更方便点。整体做法为:先进行插入排序,如果执行的过程中发现与给定的数列吻合,那么说明是插入排序,否则为归并排序。然后再输出对应排序方法的下一步结果。

注意:由于数据范围较小,归并排序可以不写合并函数,而直接用sort代替。

#include<iostream>
#include<cstdio>
#include<algorithm>
#define MAXN  111
int origin[MAXN], temp[MAXN], change[MAXN];   //初始数组、临时数组、目标数组
using namespace std;

int n;  //元素个数

int judge(int a[], int b[])   //用来判断两个数组是否相同
{
	for (int i = 0; i < n; i++)
	{
		if (a[i] != b[i])
			return 0;
	}
	return 1;
}

int insertSort()
{
	int flag = 0;
	for (int i = 1; i < n; i++)
	{
		if (i != 1&& judge(temp, change))   //中间步骤存在与给的数列相同且不是初始序列
		{
			flag = 1;
		}
		//插入排序
		int num = temp[i], j = i;
		while (j > 0 && temp[j - 1] > num)
		{
			temp[j] = temp[j - 1];
			j--;
		}
		temp[j] = num;
		if (flag == 1)
			return 1;
	}
	return 0;
}

void mergeSort()
{
	int flag = 0;
	for (int step = 2; step / 2 <= n; step *= 2)
	{
		if (step != 2&&judge(temp, change))
		{
			flag = true;
		}
		for (int i = 0; i < n; i += step)
		{
			sort(temp + i, temp + min(i + step, n));
		}
		if (flag == true)
		{
			for (int i = 0; i < n; i++)
			{
				printf("%d",temp[i]);
				if (i < n - 1)printf(" ");
			}
			printf("\n");
			return;
		}
	}
}

int main()
{
	scanf("%d",&n);
	for (int i = 0; i < n; i++)
	{
		scanf("%d", &origin[i]);   //输入起始数组
		temp[i] = origin[i];
	}
	for (int i = 0; i < n; i++)
	{
		scanf("%d", &change[i]);
	}
	if (insertSort())
	{
		printf("Insertion Sort\n");
		for (int i = 0; i < n; i++)
		{
			printf("%d",temp[i]);
			if (i < n - 1)printf(" ");
		}
		printf("\n");
	}
	else
	{
		printf("Merge Sort\n");
		for (int i = 0; i < n; i++)
		{
			temp[i] = origin[i];
		}
		mergeSort();
	}
	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

胡小涛

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值