1003 Emergency (25 分)【Dijkstra】

1003 Emergency (25 分)

As an emergency rescue team leader of a city, you are given a special map of your country. The map shows several scattered cities connected by some roads. Amount of rescue teams in each city and the length of each road between any pair of cities are marked on the map. When there is an emergency call to you from some other city, your job is to lead your men to the place as quickly as possible, and at the mean time, call up as many hands on the way as possible.
Input Specification:
Each input file contains one test case. For each test case, the first line contains 4 positive integers: N (≤500) - the number of cities (and the cities are numbered from 0 to N−1), M - the number of roads, C​1​​ and C​2​​ - the cities that you are currently in and that you must save, respectively. The next line contains N integers, where the i-th integer is the number of rescue teams in the i-th city. Then M lines follow, each describes a road with three integers c​1​​, c​2​​ and L, which are the pair of cities connected by a road and the length of that road, respectively. It is guaranteed that there exists at least one path from C​1​​ to C​2​​.
Output Specification:
For each test case, print in one line two numbers: the number of different shortest paths between C​1​​ and C​2​​, and the maximum amount of rescue teams you can possibly gather. All the numbers in a line must be separated by exactly one space, and there is no extra space allowed at the end of a line.

Sample Input:
5 6 0 2
1 2 1 5 3
0 1 1
0 2 2
0 3 1
1 2 1
2 4 1
3 4 1

Sample Output:
2 4

最短路径之Dijkstra算法(参照自柳神的分析)
题目大意:n个城市m条路,每个城市有救援小组,所有的边的边权已知。给定起点和终点,求从起点到终点的最短路径条数以及最短路径上的救援小组数目之和。如果有多条就输出点权(城市救援小组数目)最大的那个

分析:用一遍Dijkstra算法~救援小组个数相当于点权,用Dijkstra求边权最小的最短路径的条数,以及这些最短路径中点权最大的值dis[i]表示从出发点到i结点最短路径的路径长度,num[i]表示从出发点到i结点最短路径的条数,w[i]表示从出发点到i点救援队的数目之和~当判定dis[u] + e[u][v] < dis[v]的时候,不仅仅要更新dis[v],还要更新num[v] = num[u], w[v] = weight[v] + w[u]; 如果dis[u] + e[u][v] == dis[v],还要更新num[v] += num[u],而且判断一下是否权重w[v]更小,如果更小了就更新w[v] = weight[v] + w[u]。

#include<iostream>
using namespace std;
#define INF 0xffffff

int n,m,c1,c2;

int edge[510][510];     //存储各城市之间的联通关系
int weight[510];        //存储各城市的救援队数目
int dist[510];    //存储出发点到点i的最短路径的路径长度
int num[510];     //表示从出发点到i结点最短路径的条数
int w[510];         //表示从出发点到i点的救援队的数目和
int s[510];        //存储已访问的点集

void Dijkstra(int v)
{
    fill(dist, dist + 510, INF);
    dist[v]=0;
    //s[v]=1;
    w[v]=weight[v];
    num[v]=1;
    for(int i = 0;i<n;i++)
    {
        int u = -1,minx = INF;
        for(int j = 0;j<n;j++)
        {
            if(minx>dist[j]&&s[j]==0)   //在没加入到s集合中的点中寻找dist最小的点
            {
                u = j;
                minx = dist[j];
            }
        }
        if(u ==-1) break;     //不连通终止
        s[u] = 1;             //将点u加入s集合
        for(int j = 0;j<n;j++)
        {
            if(s[j]==0&&edge[u][j]!=INF)
            {
                if(dist[u]+edge[u][j]<dist[j])
                {
                    dist[j] = dist[u]+edge[u][j];
                    num[j] = num[u];
                    w[j] = w[u]+weight[j];
                }
                else if(dist[u]+edge[u][j]==dist[j])
                {
                    num[j] = num[j]+num[u];
                    if(w[u]+weight[j]>w[j])
                        w[j] = w[u]+weight[j];
                }
            }
        }
    }
}

int main()
{
    cin>>n>>m>>c1>>c2;
    for(int i = 0;i<n;i++)
        cin>>weight[i];
    //edge初始化
    for(int i = 0;i<n;i++)
        for(int j = 0;j<n;j++)
            edge[i][j] = INF;
    for(int i = 0;i<m;i++)
    {
        int a,b,l;
        cin>>a>>b>>l;
        edge[a][b] = edge[b][a] = l;
    }
    Dijkstra(c1);
    cout<<num[c2]<<" "<<w[c2]<<endl;
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

胡小涛

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值