poj 2566 Bound Found(尺取法)

Bound Found
Time Limit: 5000MS Memory Limit: 65536K
Total Submissions: 2049 Accepted: 672 Special Judge

Description

Signals of most probably extra-terrestrial origin have been received and digitalized by The Aeronautic and Space Administration (that must be going through a defiant phase: "But I want to use feet, not meters!"). Each signal seems to come in two parts: a sequence of n integer values and a non-negative integer t. We'll not go into details, but researchers found out that a signal encodes two integer values. These can be found as the lower and upper bound of a subrange of the sequence whose absolute value of its sum is closest to t.

You are given the sequence of n integers and the non-negative target t. You are to find a non-empty range of the sequence (i.e. a continuous subsequence) and output its lower index l and its upper index u. The absolute value of the sum of the values of the sequence from the l-th to the u-th element (inclusive) must be at least as close to t as the absolute value of the sum of any other non-empty range.

Input

The input file contains several test cases. Each test case starts with two numbers n and k. Input is terminated by n=k=0. Otherwise, 1<=n<=100000 and there follow n integers with absolute values <=10000 which constitute the sequence. Then follow k queries for this sequence. Each query is a target t with 0<=t<=1000000000.

Output

For each query output 3 numbers on a line: some closest absolute sum and the lower and upper indices of some range where this absolute sum is achieved. Possible indices start with 1 and go up to n.

Sample Input

5 1
-10 -5 0 5 10
3
10 2
-9 8 -7 6 -5 4 -3 2 -1 0
5 11
15 2
-1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1
15 100
0 0

Sample Output

5 4 4
5 2 8
9 1 1
15 1 15
15 1 15

Source


竟然还有这么个巧妙地方法,好久没练acm  脑子差点转不过来。题目意思在一串数字 中找出一个字串,使其和的绝对值和 k 值相差最小。输出和k值相差最小的绝对值。并输出字串的起始位置。这里提供了一个枚举字串和的一个巧妙地方法。那就是用p【i】.first来表示从最左端开始的第i个数字结尾的字串和。那么每次我枚举两个p[ ]数组元素值,相减后就相当于枚举了这个字串和吧? 那么我在对p排一下序,那么如果此时固定p的最左端(字串和最小),依次往右遍历元素p[i],即继续枚举字串和稍大一点的字串。

巧妙之处还在于在p数组最前面虚拟了一个结点。其实想想并不会影响结果的。(copy了人家的代码)

/*=============================================================================
#
#      Author: liangshu - cbam 
#
#      QQ : 756029571 
#
#      School : 哈尔滨理工大学 
#
#      Last modified: 2015-11-15 17:28
#
#     Filename: H.cpp
#
#     Description: 
#        The people who are crazy enough to think they can change the world, are the ones who do ! 
=============================================================================*/
#
#include<iostream>
#include<sstream>
#include<algorithm>
#include<cstdio>
#include<string.h>
#include<cctype>
#include<string>
#include<cmath>
#include<vector>
#include<stack>
#include<queue>
#include<map>
#include<set>
using namespace std;
const int INF = 100100;
typedef pair<int, int>P;
P p[INF];
int a[INF];

int main()
{
   int n, k, mid;
   while(scanf("%d%d", &n, &k),n + k){
    for(int i = 1; i <= n; i++){
        scanf("%d", &a[i]);
    }
        p[0] = make_pair(0, 0);
        for(int i = 1; i <= n; i++){
            p[i] = make_pair(p[i - 1].first + a[i], i);
        }
        sort(p , p + n + 1);
        while(k --){
            scanf("%d", &mid);
            int temp , s = 0, t = 1,v = 0, ans = 1 << 30,l, r;
            while(t <= n && ans){
                temp = p[t].first - p[s].first;
                if(abs(mid - temp) < ans){
                    ans = abs(mid - temp);
                    v = temp;
                    l = p[s].second;
                    r = p[t].second;
                }
                if(temp < mid){
                    t++;
                }
                else {
                    s++;
                }
                if(s == t)t++;

            }
            printf("%d %d %d\n", v, min(l, r) + 1, max(l, r));
        }

   }
   return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值