ACM-DP之Function Run Fun——hdu1331

Function Run Fun

Problem Description

We all love recursion! Don't we?

Consider a three-parameter recursive function w(a, b, c):

if a <= 0 or b <= 0 or c <= 0, then w(a, b, c) returns:
1

if a > 20 or b > 20 or c > 20, then w(a, b, c) returns:
w(20, 20, 20)

if a < b and b < c, then w(a, b, c) returns:
w(a, b, c-1) + w(a, b-1, c-1) - w(a, b-1, c)

otherwise it returns:
w(a-1, b, c) + w(a-1, b-1, c) + w(a-1, b, c-1) - w(a-1, b-1, c-1)

This is an easy function to implement. The problem is, if implemented directly, for moderate values of a, b and c (for example, a = 15, b = 15, c = 15), the program takes hours to run because of the massive recursion.

Input

The input for your program will be a series of integer triples, one per line, until the end-of-file flag of -1 -1 -1. Using the above technique, you are to calculate w(a, b, c) efficiently and print the result.

Output

Print the value for w(a,b,c) for each triple.

Sample Input

1 1 1
2 2 2
10 4 6
50 50 50
-1 7 18
-1 -1 -1 

Sample Output

w(1, 1, 1) = 2
w(2, 2, 2) = 4
w(10, 4, 6) = 523
w(50, 50, 50) = 1048576
w(-1, 7, 18) = 1

一道简单的动归题,题目中也提到15 15 15时候就要花很长时间才能算出来,所以先提前把数据算好,输入什么就相应输出就可以了
注意一点 格式问题,输出的数据括号内每个逗号后都有一个空格,等号两面均有空格。
代码如下:

#include <iostream>
using namespace std;
int arr[21][21][21];

int value(int i,int j,int k)
{
	if(i<=0 || j<=0 ||k<=0)
		return 1;
	if(i>20 || j>20 ||k>20)
		return arr[20][20][20];
	return arr[i][j][k];
}

int main()
{
	int i,j,k;
	for(i=1;i<21;++i)
		for(j=1;j<21;++j)
			for(k=1;k<21;++k)
			{
				if(i<j && j<k)
					arr[i][j][k]=value(i,j,k-1)+value(i,j-1,k-1)-value(i,j-1,k);
				else
					arr[i][j][k]=value(i-1,j,k)+value(i-1,j-1,k)+value(i-1,j,k-1)-value(i-1,j-1,k-1);
			}

	while(cin>>i>>j>>k)
	{
		if(i==-1 && j==-1 && k==-1)
			break;
	
		cout<<"w("<<i<<", "<<j<<", "<<k<<") = "<<value(i,j,k)<<endl;

	}



	return 0;
}

 
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值