poj2083(分形图)

Fractal
Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 11068 Accepted: 4957

Description

A fractal is an object or quantity that displays self-similarity, in a somewhat technical sense, on all scales. The object need not exhibit exactly the same structure at all scales, but the same "type" of structures must appear on all scales. 
A box fractal is defined as below : 
  • A box fractal of degree 1 is simply 

  • A box fractal of degree 2 is 
    X X 

    X X 
  • If using B(n - 1) to represent the box fractal of degree n - 1, then a box fractal of degree n is defined recursively as following 
    B(n - 1)        B(n - 1)
    
            B(n - 1)
    
    B(n - 1)        B(n - 1)

Your task is to draw a box fractal of degree n.

Input

The input consists of several test cases. Each line of the input contains a positive integer n which is no greater than 7. The last line of input is a negative integer −1 indicating the end of input.

Output

For each test case, output the box fractal using the 'X' notation. Please notice that 'X' is an uppercase letter. Print a line with only a single dash after each test case.

Sample Input

1
2
3
4
-1

Sample Output

X
-
X X
 X
X X
-
X X   X X
 X     X
X X   X X
   X X
    X
   X X
X X   X X
 X     X
X X   X X
-
X X   X X         X X   X X
 X     X           X     X
X X   X X         X X   X X
   X X               X X
    X                 X
   X X               X X
X X   X X         X X   X X
 X     X           X     X
X X   X X         X X   X X
         X X   X X
          X     X
         X X   X X
            X X
             X
            X X
         X X   X X
          X     X
         X X   X X
X X   X X         X X   X X
 X     X           X     X
X X   X X         X X   X X
   X X               X X
    X                 X
   X X               X X
X X   X X         X X   X X
 X     X           X     X
X X   X X         X X   X X
-

n度方盒子的规模为3的n-1次方,即一个长宽各是3的n-1次方个单位长度的正方形。通过递归子程序print(n,x,y),生成以(x,y)格为左上角的n度的方盒子。

#include<iostream>
#include<cmath>
using namespace std;
char ch[10000][10000];
void print(int n,int x,int y)
{
	if(n==1)
	{
		ch[x][y]='X';
		return ;
	}
	int size=(int)pow(3.0,n-2);
	print(n-1,x,y);//左上角 
	print(n-1,x,y+size*2);//右上角 
	print(n-1,x+size,y+size);//中间 
	print(n-1,x+size*2,y);//左下角 
	print(n-1,x+size*2,y+size*2);//右下角 
}
int main()
{
	int t;
	while(cin>>t&&t!=-1)
	{
		int ssize=(int)pow(3.0,t-1);//n度分形图规模为3^(n-1)
		//度为n,大小为ssize*ssize的图 
		for(int i=1;i<=ssize;i++)
		{
			for(int j=1;j<=ssize;j++)
			{
				ch[i][j]=' ';
			}
		}
		print(t,1,1);
		for(int i=1;i<=ssize;i++)
		{
			for(int j=1;j<=ssize;j++)
			{
				cout<<ch[i][j];
			}
			cout<<endl;
		}
		cout<<"-"<<endl;
	}
	return 0;
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值