http://acm.hdu.edu.cn/showproblem.php?pid=2199
Problem Description
Now,given the equation 8*x^4 + 7*x^3 + 2*x^2 + 3*x + 6 == Y,can you find its solution between 0 and 100;
Now please try your lucky.
Now please try your lucky.
Input
The first line of the input contains an integer T(1<=T<=100) which means the number of test cases. Then T lines follow, each line has a real number Y (fabs(Y) <= 1e10);
Output
For each test case, you should just output one real number(accurate up to 4 decimal places),which is the solution of the equation,or “No solution!”,if there is no solution for the equation between 0 and 100.
Sample Input
2 100 -4
Sample Output
1.6152 No solution!
#include <stdio.h>
#include <iostream>
#include <cmath>
using namespace std;
double y;
double fc(double x)
{
return 8*pow(x,4)+7*pow(x,3)+2*x*x+x*3+6-y;
}
int main()
{
int n;
scanf("%d",&n);
while(n--)
{
double l=0;
double r=100;
double x=-1;
scanf("%lf",&y);
if(fc(0)>0||fc(100.0)<0)
{
printf("No solution!\n");
continue;
}
else
{
while(l<r)
{
double mid=(l+r)/2;
if(fc(mid)<0.000001&&fc(mid)>-0.000001)
{
x=mid;
break;
}
else if(fc(mid)<0)
l=mid;
else
r=mid;
}
if(x==-1)
printf("No solution!\n");
else
printf("%.4f\n",x);
}
}
return 0;
}