HDU4565-So easy-数学推导化简递推矩阵快速幂

So Easy!

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3517    Accepted Submission(s): 1136


Problem Description
  A sequence S n is defined as:

Where a, b, n, m are positive integers.┌x┐is the ceil of x. For example, ┌3.14┐=4. You are to calculate S n.
  You, a top coder, say: So easy! 
 

Input
  There are several test cases, each test case in one line contains four positive integers: a, b, n, m. Where 0< a, m < 2 15, (a-1) 2< b < a 2, 0 < b, n < 2 31.The input will finish with the end of file.
 

Output
  For each the case, output an integer S n.
 

Sample Input
  
  
2 3 1 2013 2 3 2 2013 2 2 1 2013
 

Sample Output
  
  
4 14 4
 
题意:就是求出题中给出的数的值。




代码如下:
#include<bits/stdc++.h>
using namespace std;
long long a,b,n,m;
struct mat {
    long long a[2][2];
};
mat mul(mat x,mat y) {
    mat tt;
    for(int i=0;i<=1;i++)
        for(int j=0;j<=1;j++) {
            tt.a[i][j]=0;
            for(int k=0;k<=1;k++)
                tt.a[i][j]+=x.a[i][k]*y.a[k][j];
            tt.a[i][j]%=m;
        }
    return tt;
}
int main()
{
    while(scanf("%I64d%I64d%I64d%I64d",&a,&b,&n,&m)!=EOF) {
        long long f0=2;long long f1=2*a;
        if(n==0) {
            printf("%lld\n",f0);
            continue;
        }
        if(n==1) {
            printf("%lld\n",f1);
            continue;
        }
        mat base,ans;
        ans.a[0][0]=ans.a[1][1]=1;
        ans.a[1][0]=ans.a[0][1]=0;
        base.a[0][0]=((2*a)%m+m)%m;
        base.a[0][1]=((b-a*a)%m+m)%m;
        base.a[1][0]=1;
        base.a[1][1]=0;
        long long x=n-1;
       // cout << x << endl;
        while(x) {
            if(x&1) {
                ans=mul(ans,base);
            }
            base=mul(base,base);
            x/=2;
        }
        long long tot=(ans.a[0][0]*f1+ans.a[0][1]*f0)%m;
        printf("%lld\n",tot);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值