1053: C++:友元3(复数的加法)

题目描述
定义复数类,用友元函数实现两个复数的加法。

输入
输入数据有若干行。每行上有四个整数,前两个表示一个复数的实部和虚部,后两个表示另一个复数的实部和虚部。
输出
对于每一组数据,输出两个复数的和,格式参照样例输出。
样例输入 Copy
1 2 -3 -4
4 3 2 -1
1 2 -3 2
3 2 -3 1
样例输出 Copy
-2-2i
6+2i
-2+4i
0+3i

# include <iostream>
using namespace std;

class Complex
{
public:
	Complex();
	Complex(int r, int i):real(r), imag(i){}
	friend void Complex_add(Complex& c1, Complex& c2);

private:
	int real;
	int imag;
};

Complex::Complex()
{
	real = 0;
	imag = 0;
}

void Complex_add(Complex& c1, Complex& c2)
{
	Complex c;
	c.real = c1.real + c2.real;
	c.imag = c1.imag + c2.imag;

	cout << c.real;
	if (c.imag >= 0)
		cout << "+";
	cout << c.imag <<"i"<< endl;
}

int main()
{
	int a, b, c, d;

	while (cin >> a >> b >> c >> d)
	{
		Complex c1(a, b), c2(c, d);
		Complex_add(c1, c2);
	}

	return 0;
}
  • 1
    点赞
  • 3
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值