1038 Recover the Smallest Number

Given a collection of number segments, you are supposed to recover the smallest number from them. For example, given { 32, 321, 3214, 0229, 87 }, we can recover many numbers such like 32-321-3214-0229-87 or 0229-32-87-321-3214 with respect to different orders of combinations of these segments, and the smallest number is 0229-321-3214-32-87.

Input Specification:

Each input file contains one test case. Each case gives a positive integer N (≤104) followed by N number segments. Each segment contains a non-negative integer of no more than 8 digits. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the smallest number in one line. Notice that the first digit must not be zero.

Sample Input:

5 32 321 3214 0229 87

Sample Output:

22932132143287

代码长度限制

16 KB

时间限制

200 ms

内存限制

64 MB

  • 代码

    #include<iostream>
    #include<vector>
    #include<string>
    #include<math.h>
    #include<algorithm>
    #include<stack>
    using namespace std;
    string s[10001];
    **bool cmp(string a, string b)
    {
        return a + b < b + a;
    }**
    int main(){
        int n;
        cin >> n;
        for(int i = 0; i < n; i ++)
        {
            cin >> s[i];
        }
        sort(s, s + n, cmp);
        string resstr;
        for(int i = 0; i < n; i++)
        {
            resstr += s[i];
        }
        while(resstr.length() != 0 && resstr[0] == '0')
        {
            **resstr.erase(resstr.begin());**
        }
        if(resstr.length() == 0) cout << 0;
        cout << resstr;
        return 0;
    }
    
    
  • 总结

    这题的主要思路是从柳神那看的,果然很妙😄,主要在于cmp函数的应用和string的一些方法。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值