1242 Rescue

题目详情:

Rescue

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 49369    Accepted Submission(s): 16614


 

Problem Description
Angel was caught by the MOLIGPY! He was put in prison by Moligpy. The prison is described as a N * M (N, M <= 200) matrix. There are WALLs, ROADs, and GUARDs in the prison.

Angel's friends want to save Angel. Their task is: approach Angel. We assume that "approach Angel" is to get to the position where Angel stays. When there's a guard in the grid, we must kill him (or her?) to move into the grid. We assume that we moving up, down, right, left takes us 1 unit time, and killing a guard takes 1 unit time, too. And we are strong enough to kill all the guards.

You have to calculate the minimal time to approach Angel. (We can move only UP, DOWN, LEFT and RIGHT, to the neighbor grid within bound, of course.)
 

Input
First line contains two integers stand for N and M.

Then N lines follows, every line has M characters. "." stands for road, "a" stands for Angel, and "r" stands for each of Angel's friend.

Process to the end of the file.
 

Output
For each test case, your program should output a single integer, standing for the minimal time needed. If such a number does no exist, you should output a line containing "Poor ANGEL has to stay in the prison all his life."
 

Sample Input
 
 
7 8 #.#####. #.a#..r. #..#x... ..#..#.# #...##.. .#...... ........
 

Sample Output
 
 
13
 

Author
CHEN, Xue
 

Source
 

Recommend
Eddy   |   We have carefully selected several similar problems for you:  1240 1016 1010 1072 1241 
题目大意:
救天使的最短时间。
解题思路:
陷阱:天使的朋友可能不止一个,所以如果以朋友为起点,时间效率大大降低,
所以需要反向遍历。因为我们并不知道朋友的数量如果每个点都要去枚举的话,可能会超时,所以这时候我们就需要用到剪枝操作,我们直接从终点开始遍历,只要遇到朋友的位置就直接返回,这样就会快的很多,这里我们用一个优先队列去操作一番,每次都取出最小的,看看能不能满足要求,一旦满足要求就直接返回。

AC代码:
#include<iostream>
#include<queue>
#include<vector>
using namespace std;
int dir_x[4]={0,0,1,-1};
int dir_y[4]={1,-1,0,0};
class location{
    public:
        int x;
        int y;
        int steps;
        friend bool operator <(location l_1,location l_2){
            return l_1.steps>l_2.steps;
        }
};
bool limit(int x,int y,int n,int m){
    if(x<=0||y<=0||x>n||y>m) return 0;
    else return 1;
}
location BFS(vector<vector<char>>& map,int x_start,int y_start,int n,int m){
    location l_current,l_next;
    priority_queue<location> q_1;
    vector<vector<int>> sign(210,vector<int>(210,1));
    l_current.x=x_start;
    l_current.y=y_start;
    l_current.steps=0;
    q_1.push(l_current);
    while(!q_1.empty()){
        l_current=q_1.top();
        q_1.pop();
        sign[l_current.x][l_current.y]=0;
        if(map[l_current.x][l_current.y]=='r'){
            return l_current;
        }
        for(int i=0;i<4;++i){
            l_next.x=l_current.x+dir_x[i];
            l_next.y=l_current.y+dir_y[i];
            if(sign[l_next.x][l_next.y]&&limit(l_next.x,l_next.y,n,m)&&map[l_next.x][l_next.y]!='#'){
                sign[l_next.x][l_next.y]=0;   
                if(map[l_next.x][l_next.y]=='x'){
                    l_next.steps=l_current.steps+2;
                }
                else l_next.steps=l_current.steps+1;
                q_1.push(l_next);
            }
        }
    }
    l_current.steps=-1;
    return l_current;
}
int main(){
    int n,m;
    while(cin>>n>>m){
        vector<vector<char>> map(210,vector<char>(210,0));
        int x_start,y_start,x_end,y_end;
        for(int i=1;i<=n;++i){
            for(int j=1;j<=m;++j){
                cin>>map[i][j];
                if(map[i][j]=='a'){
                    x_start=i;
                    y_start=j;
                }
            }
        }
        location res=BFS(map,x_start,y_start,n,m);
        if(res.steps==-1) cout<<"Poor ANGEL has to stay in the prison all his life."<<endl;
        else cout<<res.steps<<endl;
    }

    return 0;
}

推荐几款学习编程的网站

免费在线开发平台(LTPP在线开发平台 | LTPP宇宙文档

        探索编程世界的新天地,为学生和开发者精心打造的编程平台,现已盛大开启!这个平台汇集了近4000道精心设计的编程题目,覆盖了C、C++、JavaScript、TypeScript、Go、Rust、PHP、Java、Ruby、Python3以及C#等众多编程语言,为您的编程学习之旅提供了一个全面而丰富的实践环境。

        在这里,您不仅可以查看自己的代码记录,还能轻松地在云端保存和运行代码,让编程变得更加便捷。平台还提供了私聊和群聊功能,让您可以与同行们无障碍交流,分享文件,共同进步。不仅如此,您还可以通过阅读文章、参与问答板块和在线商店,进一步拓展您的知识边界。

        为了提升您的编程技能,平台还设有每日一题、精选题单以及激动人心的编程竞赛,这些都是备考编程考试的绝佳资源。更令人兴奋的是,您还可以自定义系统UI,选择视频或图片作为背景,打造一个完全个性化的编码环境,让您的编程之旅既有趣又充满挑战。

免费公益服务器(LTPP公益LINUX服务器分享 | LTPP宇宙文档

        作为开发者或学生,您是否为搭建和维护编程环境而困扰?现在,有一款免费的公共服务器,内置多种编程语言的编程环境,并且配备了在线版VS Code。让您可以随时随地在线写代码,无需复杂配置,专注于开发和学习。(PS:毕竟是免费公共的服务器,任何人都能够使用,为了数据隐私和安全,请勿上传重要数据,仅用于学习)

免费公益MYSQL(LTPP公益MYSQL分享 | LTPP宇宙文档

        作为一名开发者或学生,您是否常常为数据库环境的搭建而烦恼?是否因为预算有限而无法使用高性能的数据库服务?现在,有一款免费的MySQL服务器,专为开发者和学生量身打造,让你轻松无忧地进行开发和学习!内置在线phpmyadmin管理面板,方便用户查看数据。(PS:毕竟是免费公共的MYSQL,任何人都能够使用,为了数据隐私和安全,请勿上传重要数据,仅用于学习)

免费在线WEB代码编辑器(LTPP在线WEB编辑器 | LTPP宇宙文档

        无论你是开发者还是学生,编程环境的搭建和管理可能会占用你宝贵的时间和精力。现在,有一款强大的免费在线代码编辑器,支持多种编程语言,让您可以随时随地编写、调试和运行代码,提升编程效率,专注于创意和开发。

免费二维码生成器(LTPP二维码生成器 | LTPP宇宙文档

        无论是企业宣传、活动推广,还是个人信息分享,二维码都是一种快速、高效的信息传递方式。现在,有一款功能强大的二维码生成器,不仅易于使用,还具备多种便捷功能,帮助您更轻松地生成和管理二维码。

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

WA-自动机

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值